aboutsummaryrefslogtreecommitdiff
path: root/archivers/xdms/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/xdms/Makefile')
-rw-r--r--archivers/xdms/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/archivers/xdms/Makefile b/archivers/xdms/Makefile
index 27e39716553b..c867d19257f8 100644
--- a/archivers/xdms/Makefile
+++ b/archivers/xdms/Makefile
@@ -18,8 +18,13 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
ALL_TARGET= xdms
+.include <bsd.port.pre.mk>
+
post-patch:
${REINPLACE_CMD} "s@-O3 -Wall@-Wall@g" ${WRKSRC}/src/Makefile.in
+.if ( ${OSVERSION} < 500000 )
+ ${REINPLACE_CMD} 's/stdint.h/inttypes.h/' ${WRKSRC}/src/cdata.h
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xdms ${PREFIX}/bin
@@ -28,4 +33,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/xdms.txt ${PREFIX}/share/doc/xdms
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>