aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
Diffstat (limited to 'archivers')
-rw-r--r--archivers/ecm/Makefile12
-rw-r--r--archivers/gzrecover/Makefile6
-rw-r--r--archivers/mar/Makefile6
-rw-r--r--archivers/ppmd/Makefile6
4 files changed, 21 insertions, 9 deletions
diff --git a/archivers/ecm/Makefile b/archivers/ecm/Makefile
index 96c8030ca6d5..b565a171656d 100644
--- a/archivers/ecm/Makefile
+++ b/archivers/ecm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ecm
-# Date created: 9 Aug 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= ecm
PORTVERSION= 1.0
@@ -23,12 +19,16 @@ MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/ecm bin/unecm
PORTDOCS= format.txt
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
do-install:
.for f in ${PORTNAME} un${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/archivers/gzrecover/Makefile b/archivers/gzrecover/Makefile
index c0c4e8f7ddca..dc40a500c124 100644
--- a/archivers/gzrecover/Makefile
+++ b/archivers/gzrecover/Makefile
@@ -20,12 +20,16 @@ CFLAGS+= -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -lz
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
do-build:
${CC} -o ${WRKSRC}/${PORTNAME} ${CFLAGS} ${WRKSRC}/${PORTNAME}.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/archivers/mar/Makefile b/archivers/mar/Makefile
index 0573e20864cc..3e4a1f3c674a 100644
--- a/archivers/mar/Makefile
+++ b/archivers/mar/Makefile
@@ -18,6 +18,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
MAN1= mar.1
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -E "s#^(CFLAGS\ |CXXFLAGS\ |CC\ |CXX\ )#\1?#" \
${WRKSRC}/src/Makefile
@@ -26,7 +30,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/man1/mar.1 ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/html/*.html ${DOCSDIR}
.endif
diff --git a/archivers/ppmd/Makefile b/archivers/ppmd/Makefile
index d3f7cee386ef..6032693712a7 100644
--- a/archivers/ppmd/Makefile
+++ b/archivers/ppmd/Makefile
@@ -15,11 +15,15 @@ MAN1= ppmd.1
PORTDOCS= read_me.txt
PLIST_FILES= bin/ppmd
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif