aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
Diffstat (limited to 'archivers')
-rw-r--r--archivers/gcpio/Makefile8
-rw-r--r--archivers/gcpio/files/patch-src_filetypes.h12
2 files changed, 13 insertions, 7 deletions
diff --git a/archivers/gcpio/Makefile b/archivers/gcpio/Makefile
index 4ce10671c5b7..282c828c76e1 100644
--- a/archivers/gcpio/Makefile
+++ b/archivers/gcpio/Makefile
@@ -37,10 +37,4 @@ MAN1= gcpio.1
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64: invalid use of stat macro
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/archivers/gcpio/files/patch-src_filetypes.h b/archivers/gcpio/files/patch-src_filetypes.h
new file mode 100644
index 000000000000..baa94df2d128
--- /dev/null
+++ b/archivers/gcpio/files/patch-src_filetypes.h
@@ -0,0 +1,12 @@
+--- src/filetypes.h.orig 2010-04-19 22:01:16.000000000 +0200
++++ src/filetypes.h 2010-04-19 22:04:16.000000000 +0200
+@@ -81,5 +81,9 @@
+ #ifndef S_ISLNK
+ #define lstat stat
+ #endif
++#ifndef lstat
+ int lstat ();
++#endif
++#ifndef stat
+ int stat ();
++#endif