aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/celestia/Makefile')
-rw-r--r--astro/celestia/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 776bfb9c8e84..ecc07ec4c628 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
-USES= gettext gmake jpeg libtool lua pkgconfig
+USES= compiler:c++11-lang gettext gl gmake jpeg libtool lua pkgconfig
USE_GL= gl
GNU_CONFIGURE= yes
EXTRA_PATCHES= ${FILESDIR}/celestia-1.6.1-lua-5.2.patch:-p1 \
@@ -48,6 +48,7 @@ USE_GL+= glut
LDFLAGS+= -lGL
.elif ${CELESTIA_UI} == "gtk"
CONFIGURE_ARGS+= --with-gtk
+USES+= gnome
USE_GNOME+= gtk20
PLIST_FILES= share/applications/celestia.desktop
.elif ${CELESTIA_UI} == "gnome"