aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia
diff options
context:
space:
mode:
Diffstat (limited to 'astro/celestia')
-rw-r--r--astro/celestia/Makefile3
-rw-r--r--astro/celestia/files/patch-src_celestia_imagecapture.cpp10
2 files changed, 12 insertions, 1 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 7e3948e2b5c6..8440cd30cf05 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -7,6 +7,7 @@
PORTNAME= celestia
PORTVERSION= 1.6.1
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Celestia-source/${PORTVERSION}
PKGNAMESUFFIX= -${CELESTIA_UI}
@@ -17,7 +18,7 @@ COMMENT= Scriptable space flight simulator for X
LICENSE= GPLv2
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
diff --git a/astro/celestia/files/patch-src_celestia_imagecapture.cpp b/astro/celestia/files/patch-src_celestia_imagecapture.cpp
new file mode 100644
index 000000000000..d365fa3eb2a1
--- /dev/null
+++ b/astro/celestia/files/patch-src_celestia_imagecapture.cpp
@@ -0,0 +1,10 @@
+--- src/celestia/imagecapture.cpp.orig 2011-06-05 18:11:13.000000000 +0200
++++ src/celestia/imagecapture.cpp 2012-04-25 05:50:24.000000000 +0200
+@@ -29,6 +29,7 @@
+ #include "../celestia/Celestia.app.skel/Contents/Frameworks/Headers/png.h"
+ #else
+ #include "png.h"
++#include "zlib.h"
+ #endif
+
+ // Define png_jmpbuf() in case we are using a pre-1.0.6 version of libpng