aboutsummaryrefslogtreecommitdiff
path: root/astro/glunarclock/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/glunarclock/Makefile')
-rw-r--r--astro/glunarclock/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/astro/glunarclock/Makefile b/astro/glunarclock/Makefile
new file mode 100644
index 000000000000..3dad5ceed24a
--- /dev/null
+++ b/astro/glunarclock/Makefile
@@ -0,0 +1,28 @@
+# Ports collection Makefile for: glunarclock
+# Date created: 31 October 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glunarclock
+PORTVERSION= 0.1
+CATEGORIES= astro gnome
+MASTER_SITES= http://www.fortunecity.de/naturpark/bienen/99/download/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GNOME= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>