aboutsummaryrefslogtreecommitdiff
path: root/astro/gmapcatcher/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/gmapcatcher/Makefile')
-rw-r--r--astro/gmapcatcher/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/astro/gmapcatcher/Makefile b/astro/gmapcatcher/Makefile
index 5e22ee913644..caa30e2eef90 100644
--- a/astro/gmapcatcher/Makefile
+++ b/astro/gmapcatcher/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gmapcatcher
-PORTVERSION= 0.7.0.0
+PORTVERSION= 0.7.1.0
CATEGORIES= astro geography
MASTER_SITES= http://gmapcatcher.googlecode.com/files/
DISTNAME= GMapCatcher-${PORTVERSION}
@@ -22,6 +22,12 @@ USE_GNOME= pygtk2
WRKSRC= ${WRKDIR}/${DISTNAME}
+DOWNLOAD_PY= ${WRKSRC}/download.py
+
+pre-patch:
+ @${TR} -d '\r' < ${DOWNLOAD_PY} > ${DOWNLOAD_PY}.tmp
+ @${MV} -f ${DOWNLOAD_PY}.tmp ${DOWNLOAD_PY}
+
post-patch:
@${FIND} ${WRKSRC} -type f -name '*.orig' -exec ${RM} {} \;
@@ -33,6 +39,7 @@ do-install:
@${MKDIR} ${PYTHON_SITELIBDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/*.py* ${PYTHON_SITELIBDIR}/${PORTNAME}
@${CP} -R ${WRKSRC}/src ${PYTHON_SITELIBDIR}/${PORTNAME}
+ @${CP} -R ${WRKSRC}/images ${PYTHON_SITELIBDIR}/${PORTNAME}
${CHMOD} +x ${PYTHON_SITELIBDIR}/${PORTNAME}/maps.py
${CHMOD} +x ${PYTHON_SITELIBDIR}/${PORTNAME}/download.py
${LN} -fs ${PYTHON_SITELIBDIR}/${PORTNAME}/maps.py \