aboutsummaryrefslogtreecommitdiff
path: root/astro/gpsdrive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/gpsdrive/Makefile')
-rw-r--r--astro/gpsdrive/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
new file mode 100644
index 000000000000..14d566417c14
--- /dev/null
+++ b/astro/gpsdrive/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gpsdrive
+# Date Created: 16 April 2002
+# Whom: Marco Molteni <molter@gufi.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpsdrive
+PORTVERSION= 1.20.r1
+CATEGORIES= astro
+MASTER_SITES= http://www.kraftvoll.at/software/ \
+ http://ganter.quant-x.at/software/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/pre/}
+
+MAINTAINER= molter@gufi.org
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+
+USE_GLIB= yes
+USE_GMAKE= yes
+USE_GTK= yes
+USE_LIBTOOL= yes
+
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+INSTALLS_SHLIB= yes
+
+MAN1= gpsdrive.1
+MANLANG= "" de es
+
+.include <bsd.port.mk>