aboutsummaryrefslogtreecommitdiff
path: root/astro/ksetiwatch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/ksetiwatch/Makefile')
-rw-r--r--astro/ksetiwatch/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/astro/ksetiwatch/Makefile b/astro/ksetiwatch/Makefile
new file mode 100644
index 000000000000..2cfec9f02274
--- /dev/null
+++ b/astro/ksetiwatch/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ksetiwatch
+# Date created: 17 January 2001
+# Whom: Sverre Valgeirsson <sverre@k9k203-3.kam.afb.lu.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ksetiwatch
+PORTVERSION= 2.2.0
+CATEGORIES= astro kde
+MASTER_SITES= http://download.sourceforge.net/ksetiwatch/
+
+MAINTAINER= sverrir@hem.passagen.se
+
+USE_KDELIBS_VER=2
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+
+pre-configure:
+ ${PERL} -pi.orig -e "s@-lqt@-lqt2@g" ${WRKSRC}/ksetiwatch/Makefile.in
+ ${PERL} -pi.orig -e "s@-lqt@-lqt2@g; s@libqt\.@libqt2\.@g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>