aboutsummaryrefslogtreecommitdiff
path: root/astro/kstars/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/kstars/Makefile')
-rw-r--r--astro/kstars/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index 16fe33c75725..d5e1e88252cb 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -5,12 +5,13 @@ PORTVERSION= ${KDE4_VERSION}
CATEGORIES= astro kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 desktop planetarium
-LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio
+LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
+ wcs:${PORTSDIR}/astro/wcslib
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2 \
xplanet:${PORTSDIR}/astro/xplanet
@@ -22,7 +23,7 @@ CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_QT4= opengl qmake_build moc_build rcc_build uic_build
-USE_XZ= yes
+USE_XZ= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>