aboutsummaryrefslogtreecommitdiff
path: root/astro/libroadnav/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/libroadnav/Makefile')
-rw-r--r--astro/libroadnav/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/astro/libroadnav/Makefile b/astro/libroadnav/Makefile
new file mode 100644
index 000000000000..011026ca12f5
--- /dev/null
+++ b/astro/libroadnav/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: roadnav
+# Date created: 28 July 2008
+# Whom: stevef
+#
+# $FreeBSD$
+#
+
+PORTNAME= libroadnav
+PORTVERSION= 0.19
+CATEGORIES= astro geography
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=roadnav
+
+MAINTAINER= stevefranks@ieee.org
+COMMENT= Helper library for Roadnav: A 3D GPS Mapping program
+
+USE_WX= 2.6+
+WX_COMPS= wx contrib
+USE_GMAKE= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-wx-prefix=${LOCALBASE} --with-wx-config=${WX_CONFIG}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+PORTDOCS= *
+
+.if defined(NOPORTDOCS)
+post-patch:
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-libroadnavdocDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>