aboutsummaryrefslogtreecommitdiff
path: root/astro/marble/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/marble/Makefile')
-rw-r--r--astro/marble/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index 48342800c816..04c7c5614053 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -2,7 +2,6 @@
PORTNAME= marble
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= astro kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -10,7 +9,9 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Virtual globe and world atlas for KDE
-USE_KDE4= kdehier kdelibs kdeprefix automoc4
+LIB_DEPENDS= libquazip.so:${PORTSDIR}/archivers/quazip
+
+USE_KDE4= kdelibs kdeprefix automoc4
USES= cmake:outsource gmake shared-mime-info tar:xz
USE_QT4= corelib dbus declarative designer_build gui network phonon \
qtestlib script sql svg webkit xml \
@@ -19,8 +20,6 @@ USE_LDCONFIG= yes
MAKE_ENV= XDG_CONFIG_HOME=/dev/null
CMAKE_ARGS= -DMOBILE:BOOL=FALSE
-LIB_DEPENDS= libquazip.so:${PORTSDIR}/archivers/quazip
-
OPTIONS_DEFINE= GPS
OPTIONS_DEFAULT= GPS
OPTIONS_SUB= yes
@@ -29,11 +28,9 @@ GPS_DESC= Support for GPS position provider
GPS_LIB_DEPENDS= libgps.so:${PORTSDIR}/astro/gpsd
GPS_CMAKE_OFF= -DWITH_libgps:BOOL=FALSE
-pre-configure:
- ${REINPLACE_CMD} -e '/libgps/ s/FIND_PACKAGE/macro_optional_find_package/' \
- ${WRKSRC}/src/plugins/positionprovider/CMakeLists.txt
-# Prevent updating MIME during build.
- ${REINPLACE_CMD} -e '/update_xdg_mimetypes/ d' \
- ${PATCH_WRKSRC}/data/CMakeLists.txt
+# pre-configure:
+# # Prevent updating MIME during build.
+# ${REINPLACE_CMD} -e '/update_xdg_mimetypes/ d' \
+# ${PATCH_WRKSRC}/data/CMakeLists.txt
.include <bsd.port.mk>