aboutsummaryrefslogtreecommitdiff
path: root/astro/marble/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/marble/Makefile')
-rw-r--r--astro/marble/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index d9547b55d5ae..bad76caccdce 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -16,9 +16,10 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Virtual globe and world atlas for KDE
-BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
LIB_DEPENDS= gps.19:${PORTSDIR}/astro/gpsd
+CONFLICTS= kdeedu-4.5.[0-5]
+
USE_BZIP2= yes
USE_CMAKE= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4
@@ -34,4 +35,9 @@ CMAKE_OUTSOURCE= yes
pre-configure:
${LN} -s ${WRKSRC}/doc/marble ${WRKSRC}/marble/marble
+post-install:
+ ${MKDIR} ${PREFIX}/share/apps/cmake/modules
+ ${INSTALL_DATA} ${WRKSRC}/cmake/modules/FindMarbleWidget.cmake \
+ ${PREFIX}/share/apps/cmake/modules
+
.include <bsd.port.mk>