aboutsummaryrefslogtreecommitdiff
path: root/astro/openmap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/openmap/Makefile')
-rw-r--r--astro/openmap/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/astro/openmap/Makefile b/astro/openmap/Makefile
index 32ceee0d84da..bd67ecdf6ea1 100644
--- a/astro/openmap/Makefile
+++ b/astro/openmap/Makefile
@@ -22,6 +22,8 @@ MAKE_ARGS+= -Dopenmap.home=${WRKSRC} \
SUB_FILES= openmap.sh
+.include <bsd.port.options.mk>
+
do-configure:
(cd ${WRKSRC} && ${FIND} . -type f -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e 's,/usr/local/openmap,${DATADIR},g')
@@ -40,7 +42,7 @@ do-install:
${MKDIR} ${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} -o ${SHAREOWN} -g ${SHAREGRP} \
AUTHORS LICENSE README ${DOCSDIR})
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
(cd ${WRKSRC}/doc && ${FIND} . -type f -print | \
${CPIO} -pdmu -R${SHAREOWN}:${SHAREGRP} ${DOCSDIR})
${FIND} ${DOCSDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 0555