aboutsummaryrefslogtreecommitdiff
path: root/astro/p5-Astro-SIMBAD/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/p5-Astro-SIMBAD/Makefile')
-rw-r--r--astro/p5-Astro-SIMBAD/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/astro/p5-Astro-SIMBAD/Makefile b/astro/p5-Astro-SIMBAD/Makefile
new file mode 100644
index 000000000000..7e33d595c148
--- /dev/null
+++ b/astro/p5-Astro-SIMBAD/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: Astro-SIMBAD
+# Date created: Oct 19, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-SIMBAD
+PORTVERSION= 1.9.3
+CATEGORIES= astro perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://www.astro.ex.ac.uk/estar/software/
+MASTER_SITE_SUBDIR= Astro
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Astro::SIMBAD::Query.3 \
+ Astro::SIMBAD::Result.3 \
+ Astro::SIMBAD::Result::Object.3
+
+.include <bsd.port.mk>