aboutsummaryrefslogtreecommitdiff
path: root/astro/p5-Astro-SpaceTrack/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/p5-Astro-SpaceTrack/Makefile')
-rw-r--r--astro/p5-Astro-SpaceTrack/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/astro/p5-Astro-SpaceTrack/Makefile b/astro/p5-Astro-SpaceTrack/Makefile
index 6f3284bb41cf..dc3ae0257275 100644
--- a/astro/p5-Astro-SpaceTrack/Makefile
+++ b/astro/p5-Astro-SpaceTrack/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= Astro-SpaceTrack
-PORTVERSION= 0.054
+PORTVERSION= 0.055
CATEGORIES= astro perl5
MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:WYANT
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
@@ -17,10 +18,11 @@ COMMENT= Retrieve orbital data from www.space-track.org
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-LWP-Protocol-https>=0:${PORTSDIR}/www/p5-LWP-Protocol-https \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
CONFIGURE_ARGS= -y
@@ -34,4 +36,8 @@ MAN3= Astro::SpaceTrack.3
RUN_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
.endif
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.include <bsd.port.post.mk>