aboutsummaryrefslogtreecommitdiff
path: root/astro/py-ephem/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/py-ephem/Makefile')
-rw-r--r--astro/py-ephem/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/astro/py-ephem/Makefile b/astro/py-ephem/Makefile
new file mode 100644
index 000000000000..141af03c1681
--- /dev/null
+++ b/astro/py-ephem/Makefile
@@ -0,0 +1,25 @@
+# Created by: db
+# $FreeBSD$
+
+PORTNAME= ephem
+PORTVERSION= 3.7.7.0
+CATEGORIES= astro math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rhurlin@gwdg.de
+COMMENT= Compute positions of the planets and stars
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/ephem/_libastro.so
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>