aboutsummaryrefslogtreecommitdiff
path: root/astro/pyephem/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/pyephem/Makefile')
-rw-r--r--astro/pyephem/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/astro/pyephem/Makefile b/astro/pyephem/Makefile
new file mode 100644
index 000000000000..8ecd71485dd9
--- /dev/null
+++ b/astro/pyephem/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: py-emphem
+# Date created: Feb 27, 2007
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyephem
+PORTVERSION= 3.7b
+CATEGORIES= astro math hamradio
+MASTER_SITES= http://www.rhodesmill.org/brandon/projects/ \
+ ${MASTER_SITE_LOCAL}
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= Scientific-grade astronomical computations for Python
+
+USE_PYTHON= 2.4+
+NO_BUILD= yes
+
+do-install:
+ (cd ${WRKSRC}; ${PYTHON_CMD} setup.py install)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/pyephem-manual.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>