aboutsummaryrefslogtreecommitdiff
path: root/astro/stellarium/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/stellarium/Makefile')
-rw-r--r--astro/stellarium/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/astro/stellarium/Makefile b/astro/stellarium/Makefile
index 4c27a85c8bf7..31a9c9bace58 100644
--- a/astro/stellarium/Makefile
+++ b/astro/stellarium/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= stellarium
-PORTVERSION= 0.12.1
+PORTVERSION= 0.12.2
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Stellarium-sources/${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -17,20 +17,21 @@ USES= cmake gettext iconv
USE_GL= glu
USE_QT4= moc_build rcc_build uic_build qmake_build \
corelib gui network opengl script
-MAKE_JOBS_SAFE= yes
+INSTALLS_ICONS= yes
MAN1= ${PORTNAME}.1
PORTDOCS= AUTHORS ChangeLog README
-OPTIONS_DEFINE= MORE_STARS DOCS
+OPTIONS_DEFINE= MORE_STARS SOUND DOCS
+OPTIONS_DEFAULT= SOUND
MORE_STARS_DESC= Install extra star catalogs (1.2GB)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMORE_STARS}
-. for i in 4 5 6 7 8
+. for i in 4 5 6 7 8
MASTER_SITES+= SF/${PORTNAME}/Extra-data-files/stars${i}:stars${i}
-. endfor
+. endfor
DISTFILES+= stars_4_1v0_0.cat:stars4 stars_5_2v0_0.cat:stars5 \
stars_6_2v0_0.cat:stars6 stars_7_2v0_0.cat:stars7 \
stars_8_2v0_0.cat:stars8
@@ -39,6 +40,12 @@ PLIST_SUB+= MORE_STARS=""
PLIST_SUB+= MORE_STARS="@comment "
.endif
+.if ${PORT_OPTIONS:MSOUND}
+USE_QT4+= phonon
+.else
+CMAKE_ARGS+= -DENABLE_SOUND:BOOL=OFF
+.endif
+
post-patch: .SILENT
${REINPLACE_CMD} -e '/QTTEST/d' ${WRKSRC}/CMakeLists.txt
# Avoid picking up the wrong `fixx11h.h' (`x11/kdelibs3' port installs one
@@ -46,12 +53,6 @@ post-patch: .SILENT
${GREP} -Rl --null fixx11h\\.h ${WRKSRC}/src ${WRKSRC}/plugins | \
${XARGS} -0 ${REINPLACE_CMD} -e 's/fixx11h\.h/fixx11qt4h.h/'
cd ${WRKSRC}/src/core/external && ${MV} fixx11h.h fixx11qt4h.h
-# Prevent spamming with empty `CMakeFiles' directories at destination
- ${REINPLACE_CMD} -e \
- '/FILES_MATCHING/s/)/PATTERN "CMakeFiles" EXCLUDE)/' \
- ${WRKSRC}/landscapes/*/CMakeLists.txt \
- ${WRKSRC}/skycultures/*/CMakeLists.txt \
- ${WRKSRC}/nebulae/default/CMakeLists.txt
post-install:
.if ${PORT_OPTIONS:MMORE_STARS}