aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
Diffstat (limited to 'astro')
-rw-r--r--astro/tclgeomap/Makefile5
-rw-r--r--astro/tkgeomap/Makefile5
2 files changed, 2 insertions, 8 deletions
diff --git a/astro/tclgeomap/Makefile b/astro/tclgeomap/Makefile
index e001ce6be531..152732688b8a 100644
--- a/astro/tclgeomap/Makefile
+++ b/astro/tclgeomap/Makefile
@@ -11,10 +11,7 @@ COMMENT= Read, manipulate, and display geo data
LICENSE= GPLv2
-USES+= tcl
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR}
+USES+= tcl:tea
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
USE_LDCONFIG= yes
diff --git a/astro/tkgeomap/Makefile b/astro/tkgeomap/Makefile
index 24f9fd25ea8e..0c89251561b3 100644
--- a/astro/tkgeomap/Makefile
+++ b/astro/tkgeomap/Makefile
@@ -13,11 +13,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libtclgeomap.so:astro/tclgeomap
-USES+= tk
-GNU_CONFIGURE= yes
+USES+= tk:tea
CONFIGURE_ARGS= --with-tclgeomap-include=${LOCALBASE}/include/tclgeomap --with-x \
- --with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR} \
- --with-tk=${TK_LIBDIR} --with-tkinclude=${TK_INCLUDEDIR} \
--x-libraries=${LOCALBASE}/lib --x-includes=${LOCALBASE}/include
MAKE_ENV+= TCLGEOMAP_LIB="-L ${LOCALBASE}/lib -ltclgeomap"
WRKSRC= ${WRKDIR}/${DISTNAME}/unix