aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
Diffstat (limited to 'astro')
-rw-r--r--astro/py-astLib/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/astro/py-astLib/Makefile b/astro/py-astLib/Makefile
index beaaed8dd727..dfc2332ba703 100644
--- a/astro/py-astLib/Makefile
+++ b/astro/py-astLib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= astLib
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= astro python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,10 +15,10 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY} \
- ${PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${FLAVOR} \
+ ${PKGNAMEPREFIX}astropy>=1.1:astro/py-astropy@${FLAVOR} \
+ ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR} \
${PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${FLAVOR} \
- ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits@${FLAVOR} \
- ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR}
+ ${PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
@@ -25,6 +26,10 @@ PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
USES= python:2.7
USE_PYTHON= autoplist distutils
+post-patch:
+ @${REINPLACE_CMD} -e 's|import pyfits|from astropy.io import fits as pyfits|' \
+ ${WRKSRC}/astLib/astPlots.py ${WRKSRC}/examples/*/*.py
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyWCSTools/*.so