aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-astropulse/Makefile5
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile5
-rw-r--r--astro/viking/Makefile5
3 files changed, 6 insertions, 9 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index c511d6341120..79864545155d 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -43,10 +43,9 @@ X11_DESC= Build screensaver (requires net/boinc-client with X11)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
- xcb:${PORTSDIR}/x11/libxcb
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
USE_GL= gl glu glut
-USE_XORG= ice sm x11 xau xext xi xdamage xdmcp xfixes xmu xt xxf86vm
+USE_XORG= ice sm x11 xau xcb xext xi xdamage xdmcp xfixes xmu xt xxf86vm
BUILD_DEPENDS+= ${LOCALBASE}/lib/libboinc_graphics2.a:${PORTSDIR}/net/boinc-client
PLIST_SUB+= X11=""
.else
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index b58bd4a916bb..d6c057a270e2 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -43,10 +43,9 @@ X11_DESC= Build screensaver (requires net/boinc-client with X11)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
- xcb:${PORTSDIR}/x11/libxcb
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
USE_GL= gl glu glut
-USE_XORG= ice sm x11 xau xext xi xdamage xdmcp xfixes xmu xt xxf86vm
+USE_XORG= ice sm x11 xau xcb xext xi xdamage xdmcp xfixes xmu xt xxf86vm
BUILD_DEPENDS+= ${LOCALBASE}/lib/libboinc_graphics2.a:${PORTSDIR}/net/boinc-client
PLIST_SUB+= X11=""
.else
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
index eae980af1904..de7622e14ae5 100644
--- a/astro/viking/Makefile
+++ b/astro/viking/Makefile
@@ -19,14 +19,13 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- xcb:${PORTSDIR}/x11/libxcb
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
USES= iconv pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext \
+USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xrandr xrender
USE_GNOME= desktopfileutils gnomedocutils gtk20
USE_PERL5_RUN= yes