aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-astropy/Makefile21
-rw-r--r--astro/py-astropy/distinfo3
-rw-r--r--astro/py-astropy/files/patch-astropy_io_fits_setup__package.py11
-rw-r--r--astro/py-astropy/files/patch-astropy_modeling_setup__package.py12
-rw-r--r--astro/py-astropy/files/patch-astropy_wcs_setup__package.py12
-rw-r--r--astro/py-astropy/pkg-descr6
7 files changed, 66 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index be08cedad90f..8006d95d634c 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -81,6 +81,7 @@
SUBDIR += py-RO
SUBDIR += py-aipy
SUBDIR += py-astLib
+ SUBDIR += py-astropy
SUBDIR += py-pyfits
SUBDIR += py-pymetar
SUBDIR += pyephem
diff --git a/astro/py-astropy/Makefile b/astro/py-astropy/Makefile
new file mode 100644
index 000000000000..3473f1dbe03c
--- /dev/null
+++ b/astro/py-astropy/Makefile
@@ -0,0 +1,21 @@
+# Created by: nwhitehorn
+# $FreeBSD$
+
+PORTNAME= astropy
+PORTVERSION= 1.1.2
+CATEGORIES= astro
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nwhitehorn@FreeBSD.org
+COMMENT= Community-developed python astronomy tools
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/astro/py-astropy/distinfo b/astro/py-astropy/distinfo
new file mode 100644
index 000000000000..2f23e3987cb1
--- /dev/null
+++ b/astro/py-astropy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465919806
+SHA256 (astropy-1.1.2.tar.gz) = 6f0d84cd7dfb304bb437dda666406a1d42208c16204043bc920308ff8ffdfad1
+SIZE (astropy-1.1.2.tar.gz) = 8059713
diff --git a/astro/py-astropy/files/patch-astropy_io_fits_setup__package.py b/astro/py-astropy/files/patch-astropy_io_fits_setup__package.py
new file mode 100644
index 000000000000..6926c24440a4
--- /dev/null
+++ b/astro/py-astropy/files/patch-astropy_io_fits_setup__package.py
@@ -0,0 +1,11 @@
+--- astropy/io/fits/setup_package.py.orig 2016-07-02 18:54:36 UTC
++++ astropy/io/fits/setup_package.py
+@@ -39,7 +39,7 @@ def _get_compression_extension():
+ '-Wno-uninitialized', '-Wno-format',
+ '-Wno-strict-prototypes', '-Wno-unused', '-Wno-comments',
+ '-Wno-switch', '-Wno-strict-aliasing', '-Wno-return-type',
+- '-Wno-address', '-Wno-unused-result'
++ '-Wno-address'
+ ])
+
+ cfitsio_path = os.path.join('cextern', 'cfitsio')
diff --git a/astro/py-astropy/files/patch-astropy_modeling_setup__package.py b/astro/py-astropy/files/patch-astropy_modeling_setup__package.py
new file mode 100644
index 000000000000..98bdaa5f7dda
--- /dev/null
+++ b/astro/py-astropy/files/patch-astropy_modeling_setup__package.py
@@ -0,0 +1,12 @@
+--- astropy/modeling/setup_package.py.orig 2016-03-10 22:20:43 UTC
++++ astropy/modeling/setup_package.py
+@@ -123,8 +123,7 @@ def preprocess_source():
+
+ def get_package_data():
+ return {
+- 'astropy.modeling.tests': ['data/*.fits', 'data/*.hdr',
+- '../../wcs/tests/maps/*.hdr']
++ 'astropy.modeling.tests': ['data/*.fits', 'data/*.hdr' ]
+ }
+
+
diff --git a/astro/py-astropy/files/patch-astropy_wcs_setup__package.py b/astro/py-astropy/files/patch-astropy_wcs_setup__package.py
new file mode 100644
index 000000000000..b4b0629e40e8
--- /dev/null
+++ b/astro/py-astropy/files/patch-astropy_wcs_setup__package.py
@@ -0,0 +1,12 @@
+--- astropy/wcs/setup_package.py.orig 2016-07-02 18:53:24 UTC
++++ astropy/wcs/setup_package.py
+@@ -244,8 +244,7 @@ def get_wcslib_cfg(cfg, wcslib_files, in
+ '-Wno-strict-prototypes',
+ '-Wno-unused-function',
+ '-Wno-unused-value',
+- '-Wno-uninitialized',
+- '-Wno-unused-but-set-variable'])
++ '-Wno-uninitialized'])
+
+
+
diff --git a/astro/py-astropy/pkg-descr b/astro/py-astropy/pkg-descr
new file mode 100644
index 000000000000..acce28f2744c
--- /dev/null
+++ b/astro/py-astropy/pkg-descr
@@ -0,0 +1,6 @@
+Astropy is a package intended to contain core functionality and some common
+tools needed for performing astronomy and astrophysics research with Python. It
+also provides an index for other astronomy packages and tools for managing
+them.
+
+WWW: http://www.astropy.org