aboutsummaryrefslogtreecommitdiff
path: root/audio/akode-plugins-oss/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/akode-plugins-oss/Makefile')
-rw-r--r--audio/akode-plugins-oss/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/audio/akode-plugins-oss/Makefile b/audio/akode-plugins-oss/Makefile
index 2008dd616b1c..fbee68cfc652 100644
--- a/audio/akode-plugins-oss/Makefile
+++ b/audio/akode-plugins-oss/Makefile
@@ -5,15 +5,14 @@
# $FreeBSD$
#
-PORTNAME= akode-plugins-${PORTNAMESUFX}
-PORTVERSION= 2.0.2
-PORTEPOCH= 1
-CATEGORIES= audio kde
-MASTER_SITES= ${MASTER_SITE_GENTOO}
-MASTER_SITE_SUBDIR=distfiles
-DISTNAME= 30375-akode-${PORTVERSION}.tar.bz2
-
-EXTRACT_SUFX= # none
+PORTNAME= akode-plugins-${PORTNAMESUFX}
+PORTVERSION= 2.0.2
+PORTEPOCH= 1
+CATEGORIES= audio kde
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
+DISTNAME= 30375-akode-${PORTVERSION}.tar.bz2
+EXTRACT_SUFX=
MAINTAINER= kde@FreeBSD.org
COMMENT= OSS output plugin for akode
@@ -24,12 +23,16 @@ PLUGIN= oss_sink
PORTNAMESUFX= ${PLUGIN:S/_sink//:S/_decoder//:S/src_//}
USE_AUTOTOOLS= libltdl
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/akode-${PORTVERSION}
USE_LDCONFIG= yes
+PLIST_FILES= lib/libakode_oss_sink.a \
+ lib/libakode_oss_sink.la \
+ lib/libakode_oss_sink.so
+
CONFIGURE_ENV+= LDFLAGS=-L${WRKSRC}/akode/lib/.libs
CONFIGURE_ARGS+=--with-extra-libs=${LOCALBASE}/lib \
--with-extra-includes=${LOCALBASE}/include