aboutsummaryrefslogtreecommitdiff
path: root/audio/akode-plugins-xiph
diff options
context:
space:
mode:
Diffstat (limited to 'audio/akode-plugins-xiph')
-rw-r--r--audio/akode-plugins-xiph/Makefile1
-rw-r--r--audio/akode-plugins-xiph/files/patch-akode_plugins_xiph__decoder_flac113__decoder.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/audio/akode-plugins-xiph/Makefile b/audio/akode-plugins-xiph/Makefile
index a6469e6d9b06..5635e7d24397 100644
--- a/audio/akode-plugins-xiph/Makefile
+++ b/audio/akode-plugins-xiph/Makefile
@@ -7,6 +7,7 @@
PORTNAME= akode-plugins-${PORTNAMESUFX}
PORTVERSION= 2.0.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_GENTOO}
diff --git a/audio/akode-plugins-xiph/files/patch-akode_plugins_xiph__decoder_flac113__decoder.cpp b/audio/akode-plugins-xiph/files/patch-akode_plugins_xiph__decoder_flac113__decoder.cpp
new file mode 100644
index 000000000000..3ca2593f4bf1
--- /dev/null
+++ b/audio/akode-plugins-xiph/files/patch-akode_plugins_xiph__decoder_flac113__decoder.cpp
@@ -0,0 +1,11 @@
+--- akode/plugins/xiph_decoder/flac113_decoder.cpp.orig 2008-03-27 16:11:26.000000000 +0100
++++ akode/plugins/xiph_decoder/flac113_decoder.cpp 2008-03-27 16:11:46.000000000 +0100
+@@ -108,7 +108,7 @@ struct FLACDecoder::private_data {
+ static FLAC__StreamDecoderReadStatus flac_read_callback(
+ const FLAC__StreamDecoder *,
+ FLAC__byte buffer[],
+- unsigned *bytes,
++ size_t *bytes,
+ void *client_data)
+ {
+ FLACDecoder::private_data *data = (FLACDecoder::private_data*)client_data;