aboutsummaryrefslogtreecommitdiff
path: root/audio/amarok-kde4/files
diff options
context:
space:
mode:
Diffstat (limited to 'audio/amarok-kde4/files')
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp29
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp18
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp16
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1.c11
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1__porter.c11
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1__tokenizer1.c11
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_statusbar_statusbar.cpp11
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_xmlloader.h13
-rw-r--r--audio/amarok-kde4/files/patch-configure34
15 files changed, 0 insertions, 238 deletions
diff --git a/audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp b/audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp
deleted file mode 100644
index 6a642616d67b..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/lastfm.cpp.orig
-+++ amarok/src/lastfm.cpp
-@@ -905,7 +905,7 @@
-
- QCString md5pass = KMD5( KMD5( m_password.utf8() ).hexDigest() + currentTime ).hexDigest();
-
-- QString token = QString( "user=%1&auth=%2&nonce=%3recipient=%4" )
-+ token = QString( "user=%1&auth=%2&nonce=%3recipient=%4" )
- .arg( QString( QUrl( currentUsername() ).encodedPathAndQuery() ) )
- .arg( QString( QUrl( md5pass ).encodedPathAndQuery() ) )
- .arg( QString( QUrl( challenge ).encodedPathAndQuery() ) )
diff --git a/audio/amarok-kde4/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp b/audio/amarok-kde4/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp
deleted file mode 100644
index e63530991f61..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/magnatunebrowser/magnatunealbumdownloader.cpp.orig
-+++ amarok/src/magnatunebrowser/magnatunealbumdownloader.cpp
-@@ -89,19 +89,19 @@
-
- //ok, now we have the .zip file downloaded. All we need is to unpack it to the desired location and add it to the collection.
-
-- QString unzipString = "unzip \""+m_tempDir.name() + m_currentAlbumFileName + "\" -d \"" + m_currentAlbumUnpackLocation + "\" &";
-+ QString unzipString = "unzip "+ KProcess::quote( m_tempDir.name() + m_currentAlbumFileName) + " -d " +KProcess::quote( m_currentAlbumUnpackLocation ) + " &";
-
- debug() << "unpacking: " << unzipString << endl;
-
- system( unzipString.ascii() );
-
--
-+
-
- if (m_currentAlbumId != -1 ) {
-
-- //now I really want to add the album cover to the same folder where I just unzipped the album... The
-+ //now I really want to add the album cover to the same folder where I just unzipped the album... The
- //only way of getting the actual location where the album was unpacked is using the artist and album names
--
-+
- MagnatuneAlbum album = MagnatuneDatabaseHandler::instance()->getAlbumById( m_currentAlbumId );
- MagnatuneArtist artist = MagnatuneDatabaseHandler::instance()->getArtistById( album.getArtistId() );
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp b/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp
deleted file mode 100644
index be021742b252..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- amarok/src/mediadevice/generic/genericmediadevice.cpp.orig Mon Feb 12 23:01:20 2007
-+++ amarok/src/mediadevice/generic/genericmediadevice.cpp Mon Feb 12 23:01:29 2007
-@@ -418,13 +418,7 @@
- if( m_medium.mountPoint() == (*mountiter)->mountPoint() )
- m_medium.setFsType( (*mountiter)->mountType() );
- }
-- m_actuallyVfat = m_medium.fsType() ==
--#ifdef __FreeBSD__
-- "msdosfs"
--#else
-- "vfat"
--#endif
-- ? true : false;
-+ m_actuallyVfat = (m_medium.fsType() == "vfat" || m_medium.fsType() == "msdosfs") ? true : false;
- m_connected = true;
- m_transferDir = m_medium.mountPoint();
- m_initialFile = new GenericMediaFile( 0, m_medium.mountPoint(), this );
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in b/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in
deleted file mode 100644
index 0a969a69e2a3..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/audible/Makefile.in.orig
-+++ amarok/src/metadata/audible/Makefile.in
-@@ -435,7 +435,7 @@
- xmms_cflags = @xmms_cflags@
- xmms_libs = @xmms_libs@
- SUBDIRS =
--INCLUDES = $(all_includes) $(taglib_includes)
-+INCLUDES = -I$(top_srcdir)/amarok/src $(all_includes) $(taglib_includes)
- #>- METASOURCES = AUTO
- libtagaudible_la_LDFLAGS = $(all_libraries)
- noinst_LTLIBRARIES = libtagaudible.la
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h b/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h
deleted file mode 100644
index 253f54878017..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/audible/audibleproperties.h.orig
-+++ amarok/src/metadata/audible/audibleproperties.h
-@@ -9,6 +9,8 @@
-
- #include <config.h>
-
-+#include <stdio.h>
-+#include <sys/types.h>
- #include <taglib/audioproperties.h>
- #include <taglib/tstring.h>
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h b/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h
deleted file mode 100644
index 65941ffd4602..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/audible/audibletag.h.orig
-+++ amarok/src/metadata/audible/audibletag.h
-@@ -9,6 +9,8 @@
-
- #include <config.h>
-
-+#include <stdio.h>
-+#include <sys/types.h>
- #include <taglib/tag.h>
- #include "taglib_audiblefile.h"
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp b/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp
deleted file mode 100644
index 35000f132539..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/mp4/mp4file.cpp.orig
-+++ amarok/src/metadata/mp4/mp4file.cpp
-@@ -23,9 +23,8 @@
-
- #include "mp4tag.h"
- #include <tfile.h>
--#include <audioproperties.h>
-
--#include <stdint.h>
-+#include <inttypes.h>
-
- #define MP4V2_HAS_WRITE_BUG 1
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp b/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp
deleted file mode 100644
index 7f39cdfb69c2..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/mp4/mp4properties.cpp.orig
-+++ amarok/src/metadata/mp4/mp4properties.cpp
-@@ -29,7 +29,7 @@
- #include <systems.h>
- #endif
-
--#include <stdint.h>
-+#include <inttypes.h>
-
- using namespace TagLib;
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp b/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp
deleted file mode 100644
index 0121a707e195..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/mp4/mp4tag.cpp.orig
-+++ amarok/src/metadata/mp4/mp4tag.cpp
-@@ -23,7 +23,7 @@
- #include "mp4tag.h"
-
- #include <tag.h>
--#include <stdint.h>
-+#include <inttypes.h>
-
- using namespace TagLib;
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1.c b/audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1.c
deleted file mode 100644
index 40b90d0fd218..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- amarok/src/sqlite/fts1.c.orig Thu Feb 1 23:14:17 2007
-+++ amarok/src/sqlite/fts1.c Sat Feb 3 01:51:38 2007
-@@ -19,7 +19,7 @@
- #endif
-
- #include <assert.h>
--#if !defined(__APPLE__)
-+#if !defined(__APPLE__) && !defined(__FreeBSD__)
- #include <malloc.h>
- #else
- #include <stdlib.h>
diff --git a/audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1__porter.c b/audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1__porter.c
deleted file mode 100644
index d0ff8ef54bbe..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1__porter.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- amarok/src/sqlite/fts1_porter.c.orig Thu Feb 1 23:14:17 2007
-+++ amarok/src/sqlite/fts1_porter.c Sat Feb 3 01:51:55 2007
-@@ -26,7 +26,7 @@
-
-
- #include <assert.h>
--#if !defined(__APPLE__)
-+#if !defined(__APPLE__) && !defined(__FreeBSD__)
- #include <malloc.h>
- #else
- #include <stdlib.h>
diff --git a/audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1__tokenizer1.c b/audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1__tokenizer1.c
deleted file mode 100644
index 81accd1f733e..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_sqlite_fts1__tokenizer1.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- amarok/src/sqlite/fts1_tokenizer1.c.orig Thu Feb 1 23:14:17 2007
-+++ amarok/src/sqlite/fts1_tokenizer1.c Sat Feb 3 01:52:07 2007
-@@ -18,7 +18,7 @@
-
-
- #include <assert.h>
--#if !defined(__APPLE__)
-+#if !defined(__APPLE__) && !defined(__FreeBSD__)
- #include <malloc.h>
- #else
- #include <stdlib.h>
diff --git a/audio/amarok-kde4/files/patch-amarok_src_statusbar_statusbar.cpp b/audio/amarok-kde4/files/patch-amarok_src_statusbar_statusbar.cpp
deleted file mode 100644
index 6b19af04d246..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_statusbar_statusbar.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- amarok/src/statusbar/statusbar.cpp.orig Mon Dec 18 00:17:13 2006
-+++ amarok/src/statusbar/statusbar.cpp Mon Dec 18 00:13:27 2006
-@@ -81,7 +81,7 @@
- m_slider->setMinimumWidth( m_timeLabel->width() );
-
- m_timeLabel2 = new TimeLabel( positionBox );
-- m_slider->setMinimumWidth( m_timeLabel2->width() );
-+ m_slider->setMinimumWidth( m_timeLabel2->width() + 128 );
-
-
- // TODO Both labels need tooltips (string freeze?)
diff --git a/audio/amarok-kde4/files/patch-amarok_src_xmlloader.h b/audio/amarok-kde4/files/patch-amarok_src_xmlloader.h
deleted file mode 100644
index 51200453662c..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_xmlloader.h
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/xmlloader.h.orig
-+++ amarok/src/xmlloader.h
-@@ -173,6 +173,7 @@
-
- public: //fucking moc, these should be private
- class ThreadedLoader;
-+ friend class ThreadedLoader;
- class SimpleLoader;
- };
-
diff --git a/audio/amarok-kde4/files/patch-configure b/audio/amarok-kde4/files/patch-configure
deleted file mode 100644
index 45a89f01ae5b..000000000000
--- a/audio/amarok-kde4/files/patch-configure
+++ /dev/null
@@ -1,34 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig
-+++ configure
-@@ -39576,7 +39576,7 @@
- if test "$with_libvisual" = "yes"; then
- ## libvisual plugin depends on sdl
- # Extract the first word of "sdl-config", so it can be a program name with args.
--set dummy sdl-config; ac_word=$2
-+set dummy $SDL_CONFIG; ac_word=$2
- { echo "$as_me:$LINENO: checking for $ac_word" >&5
- echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
- if test "${ac_cv_prog_SDL_CONFIG+set}" = set; then
-@@ -39613,15 +39613,15 @@
-
-
-
-- if test x$SDL_CONFIG = xyes; then
-- sdl_cflags=`sdl-config --cflags`
-- sdl_libs=`sdl-config --libs`
-+ if test -n $SDL_CONFIG ; then
-+ sdl_cflags=`$SDL_CONFIG --cflags`
-+ sdl_libs=`$SDL_CONFIG --libs`
- fi
-
-
-
-
-- if test x$PKGCONFIGFOUND = xyes -a x$SDL_CONFIG = xyes; then
-+ if test x$PKGCONFIGFOUND = xyes -a -n $SDL_CONFIG ; then
-
-
- succeeded=no