aboutsummaryrefslogtreecommitdiff
path: root/audio/amarok-kde4/files
diff options
context:
space:
mode:
Diffstat (limited to 'audio/amarok-kde4/files')
-rw-r--r--audio/amarok-kde4/files/hide-main-menu-bar-feature.patch119
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp29
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp14
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_statusbar_statusbar.cpp11
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_xmlloader.h13
-rw-r--r--audio/amarok-kde4/files/patch-configure34
11 files changed, 0 insertions, 290 deletions
diff --git a/audio/amarok-kde4/files/hide-main-menu-bar-feature.patch b/audio/amarok-kde4/files/hide-main-menu-bar-feature.patch
deleted file mode 100644
index dc53b53a6d2b..000000000000
--- a/audio/amarok-kde4/files/hide-main-menu-bar-feature.patch
+++ /dev/null
@@ -1,119 +0,0 @@
-diff -ruN amarok.orig/src/amarokcore/amarok.kcfg amarok/src/amarokcore/amarok.kcfg
---- amarok.orig/src/amarokcore/amarok.kcfg Mon Jun 18 01:51:49 2007
-+++ amarok/src/amarokcore/amarok.kcfg Thu Jun 21 22:42:23 2007
-@@ -216,6 +216,11 @@
- <whatsthis>Set this to the style dir you want to use.</whatsthis>
- <default>Default</default>
- </entry>
-+ <entry key="Show Menu Bar" type="Bool">
-+ <label>Whether Menubar is shown</label>
-+ <whatsthis>If set, Amarok displays a menubar on top of the application.</whatsthis>
-+ <default>true</default>
-+ </entry>
- <entry key="Relative Playlist" type="Bool">
- <label>Whether playlists store relative path</label>
- <whatsthis>If set, Amarok's manually saved playlists will contain a relative path to each track, not an absolute path.</whatsthis>
-diff -ruN amarok.orig/src/app.cpp amarok/src/app.cpp
---- amarok.orig/src/app.cpp Mon Jun 18 01:51:49 2007
-+++ amarok/src/app.cpp Thu Jun 21 22:43:27 2007
-@@ -678,6 +674,11 @@
- m_pPlaylistWindow->setCaption( i18n("Amarok - %1").arg( EngineController::instance()->bundle().veryNiceTitle() ) );
- else
- m_pPlaylistWindow->setCaption( "Amarok" );
-+
-+ //m_pPlaylistWindow->show(); //must be shown //we do below now
-+ //ensure that at least one Menu is plugged into an accessible UI element
-+ if( !AmarokConfig::showMenuBar() && !Amarok::actionCollection()->action( "amarok_menu" )->isPlugged() )
-+ playlistWindow()->createGUI();
- }
-
- playlistWindow()->applySettings();
-diff -ruN amarok.orig/src/playlistwindow.cpp amarok/src/playlistwindow.cpp
---- amarok.orig/src/playlistwindow.cpp Mon Jun 18 01:51:49 2007
-+++ amarok/src/playlistwindow.cpp Thu Jun 21 22:48:15 2007
-@@ -139,6 +139,7 @@
- ac->action( "stream_add" )->setIcon( Amarok::icon( "files" ) );
- KStdAction::save( this, SLOT(savePlaylist()), ac, "playlist_save" )->setText( i18n("&Save Playlist As...") );
- ac->action( "playlist_save" )->setIcon( Amarok::icon( "save" ) );
-+ KStdAction::showMenubar( this, SLOT(slotToggleMenu()), ac );
-
- //FIXME: after string freeze rename to "Burn Current Playlist"?
- new KAction( i18n("Burn to CD"), Amarok::icon( "burn" ), 0, this, SLOT(slotBurnPlaylist()), ac, "playlist_burn" );
-@@ -233,6 +236,7 @@
-
- PlaylistWindow::~PlaylistWindow()
- {
-+ Amarok::config( "PlaylistWindow" )->writeEntry( "showMenuBar", m_menubar->isShown() );
- AmarokConfig::setPlaylistWindowPos( pos() ); //TODO de XT?
- AmarokConfig::setPlaylistWindowSize( size() ); //TODO de XT?
- }
-@@ -307,6 +310,7 @@
- connect( repeatAction, SIGNAL( activated( int ) ), playlist, SLOT( slotRepeatTrackToggled( int ) ) );
-
- m_menubar = new KMenuBar( this );
-+ m_menubar->setShown( AmarokConfig::showMenuBar() );
-
- //BEGIN Actions menu
- KPopupMenu *actionsMenu = new KPopupMenu( m_menubar );
-@@ -381,6 +388,8 @@
- m_settingsMenu = new KPopupMenu( m_menubar );
- //TODO use KStdAction or KMainWindow
- #ifndef Q_WS_MAC
-+ static_cast<KToggleAction *>(actionCollection()->action(KStdAction::name(KStdAction::ShowMenubar)))->setChecked( AmarokConfig::showMenuBar() );
-+ actionCollection()->action(KStdAction::name(KStdAction::ShowMenubar))->plug( m_settingsMenu );
- m_settingsMenu->insertItem( AmarokConfig::showToolbar() ? i18n( "Hide Toolbar" ) : i18n("Show Toolbar"), ID_SHOW_TOOLBAR );
- m_settingsMenu->insertItem( AmarokConfig::showPlayerWindow() ? i18n("Hide Player &Window") : i18n("Show Player &Window"), ID_SHOW_PLAYERWINDOW );
- m_settingsMenu->insertSeparator();
-@@ -569,6 +578,12 @@
- for( QStringList::ConstIterator it = list.constBegin(); it != end; ++it )
- {
- KToolBarButton* const button = static_cast<KToolBarButton*>( m_toolbar->child( (*it).latin1() ) );
-+ if ( it == last ) {
-+ //if the user has no PlayerWindow, he MUST have the menu action plugged
-+ //NOTE this is not saved to the local XMLFile, which is what the user will want
-+ if ( !AmarokConfig::showPlayerWindow() && !AmarokConfig::showMenuBar() && !button )
-+ actionCollection()->action( "amarok_menu" )->plug( m_toolbar );
-+ }
-
- if ( button ) {
- button->modeChange();
-@@ -1031,6 +1046,20 @@
- Playlist::instance()->setFocus();
- }
-
-+void PlaylistWindow::slotToggleMenu() //SLOT
-+{
-+ if( static_cast<KToggleAction *>(actionCollection()->action(KStdAction::name(KStdAction::ShowMenubar)))->isChecked() ) {
-+ AmarokConfig::setShowMenuBar( true );
-+ m_menubar->setShown( true );
-+ }
-+ else
-+ {
-+ AmarokConfig::setShowMenuBar( false );
-+ m_menubar->setShown( false );
-+ }
-+ recreateGUI();
-+}
-+
- void PlaylistWindow::slotMenuActivated( int index ) //SLOT
- {
- switch( index )
-@@ -1042,6 +1071,7 @@
- case ID_SHOW_TOOLBAR:
- m_toolbar->setShown( !m_toolbar->isShown() );
- AmarokConfig::setShowToolbar( !AmarokConfig::showToolbar() );
-+ actionCollection()->action(KStdAction::name(KStdAction::ShowMenubar))->setEnabled( m_toolbar->isShown() );
- m_settingsMenu->changeItem( index, m_toolbar->isShown() ? i18n("Hide Toolbar") : i18n("Show Toolbar") );
- break;
- case ID_SHOW_PLAYERWINDOW:
-diff -ruN amarok.orig/src/playlistwindow.h amarok/src/playlistwindow.h
---- amarok.orig/src/playlistwindow.h Mon Jun 18 01:51:49 2007
-+++ amarok/src/playlistwindow.h Thu Jun 21 22:48:44 2007
-@@ -91,6 +91,7 @@
- void slotMenuActivated( int );
- void actionsMenuAboutToShow();
- void toolsMenuAboutToShow();
-+ void slotToggleMenu();
- void slotToggleFocus();
- void slotEditFilter();
- void slotSetFilter( const QString &filter );
diff --git a/audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp b/audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp
deleted file mode 100644
index 6a642616d67b..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_lastfm.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/lastfm.cpp.orig
-+++ amarok/src/lastfm.cpp
-@@ -905,7 +905,7 @@
-
- QCString md5pass = KMD5( KMD5( m_password.utf8() ).hexDigest() + currentTime ).hexDigest();
-
-- QString token = QString( "user=%1&auth=%2&nonce=%3recipient=%4" )
-+ token = QString( "user=%1&auth=%2&nonce=%3recipient=%4" )
- .arg( QString( QUrl( currentUsername() ).encodedPathAndQuery() ) )
- .arg( QString( QUrl( md5pass ).encodedPathAndQuery() ) )
- .arg( QString( QUrl( challenge ).encodedPathAndQuery() ) )
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in b/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in
deleted file mode 100644
index 0a969a69e2a3..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/audible/Makefile.in.orig
-+++ amarok/src/metadata/audible/Makefile.in
-@@ -435,7 +435,7 @@
- xmms_cflags = @xmms_cflags@
- xmms_libs = @xmms_libs@
- SUBDIRS =
--INCLUDES = $(all_includes) $(taglib_includes)
-+INCLUDES = -I$(top_srcdir)/amarok/src $(all_includes) $(taglib_includes)
- #>- METASOURCES = AUTO
- libtagaudible_la_LDFLAGS = $(all_libraries)
- noinst_LTLIBRARIES = libtagaudible.la
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h b/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h
deleted file mode 100644
index 253f54878017..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibleproperties.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/audible/audibleproperties.h.orig
-+++ amarok/src/metadata/audible/audibleproperties.h
-@@ -9,6 +9,8 @@
-
- #include <config.h>
-
-+#include <stdio.h>
-+#include <sys/types.h>
- #include <taglib/audioproperties.h>
- #include <taglib/tstring.h>
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h b/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h
deleted file mode 100644
index 65941ffd4602..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_audible_audibletag.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/audible/audibletag.h.orig
-+++ amarok/src/metadata/audible/audibletag.h
-@@ -9,6 +9,8 @@
-
- #include <config.h>
-
-+#include <stdio.h>
-+#include <sys/types.h>
- #include <taglib/tag.h>
- #include "taglib_audiblefile.h"
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp b/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp
deleted file mode 100644
index 181d18e156a0..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4file.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/mp4/mp4file.cpp.orig
-+++ amarok/src/metadata/mp4/mp4file.cpp
-@@ -27,9 +27,8 @@
-
- #include "mp4tag.h"
- #include <tfile.h>
--#include <audioproperties.h>
-
--#include <stdint.h>
-+#include <inttypes.h>
-
- #define MP4V2_HAS_WRITE_BUG 1
-
-@@ -156,10 +155,8 @@
- }
- #endif
-
-- if(!MP4Close(handle))
-- {
-- fprintf(stderr, "close failed\n");
-- }
-+ MP4Close(handle);
-+ handle=NULL;
-
- mp4file = MP4Read(name());
- if(mp4file == MP4_INVALID_FILE_HANDLE)
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp b/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp
deleted file mode 100644
index 7f39cdfb69c2..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4properties.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/mp4/mp4properties.cpp.orig
-+++ amarok/src/metadata/mp4/mp4properties.cpp
-@@ -29,7 +29,7 @@
- #include <systems.h>
- #endif
-
--#include <stdint.h>
-+#include <inttypes.h>
-
- using namespace TagLib;
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp b/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp
deleted file mode 100644
index 0121a707e195..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_metadata_mp4_mp4tag.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/metadata/mp4/mp4tag.cpp.orig
-+++ amarok/src/metadata/mp4/mp4tag.cpp
-@@ -23,7 +23,7 @@
- #include "mp4tag.h"
-
- #include <tag.h>
--#include <stdint.h>
-+#include <inttypes.h>
-
- using namespace TagLib;
-
diff --git a/audio/amarok-kde4/files/patch-amarok_src_statusbar_statusbar.cpp b/audio/amarok-kde4/files/patch-amarok_src_statusbar_statusbar.cpp
deleted file mode 100644
index 6b19af04d246..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_statusbar_statusbar.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- amarok/src/statusbar/statusbar.cpp.orig Mon Dec 18 00:17:13 2006
-+++ amarok/src/statusbar/statusbar.cpp Mon Dec 18 00:13:27 2006
-@@ -81,7 +81,7 @@
- m_slider->setMinimumWidth( m_timeLabel->width() );
-
- m_timeLabel2 = new TimeLabel( positionBox );
-- m_slider->setMinimumWidth( m_timeLabel2->width() );
-+ m_slider->setMinimumWidth( m_timeLabel2->width() + 128 );
-
-
- // TODO Both labels need tooltips (string freeze?)
diff --git a/audio/amarok-kde4/files/patch-amarok_src_xmlloader.h b/audio/amarok-kde4/files/patch-amarok_src_xmlloader.h
deleted file mode 100644
index 51200453662c..000000000000
--- a/audio/amarok-kde4/files/patch-amarok_src_xmlloader.h
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- amarok/src/xmlloader.h.orig
-+++ amarok/src/xmlloader.h
-@@ -173,6 +173,7 @@
-
- public: //fucking moc, these should be private
- class ThreadedLoader;
-+ friend class ThreadedLoader;
- class SimpleLoader;
- };
-
diff --git a/audio/amarok-kde4/files/patch-configure b/audio/amarok-kde4/files/patch-configure
deleted file mode 100644
index 45a89f01ae5b..000000000000
--- a/audio/amarok-kde4/files/patch-configure
+++ /dev/null
@@ -1,34 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig
-+++ configure
-@@ -39576,7 +39576,7 @@
- if test "$with_libvisual" = "yes"; then
- ## libvisual plugin depends on sdl
- # Extract the first word of "sdl-config", so it can be a program name with args.
--set dummy sdl-config; ac_word=$2
-+set dummy $SDL_CONFIG; ac_word=$2
- { echo "$as_me:$LINENO: checking for $ac_word" >&5
- echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
- if test "${ac_cv_prog_SDL_CONFIG+set}" = set; then
-@@ -39613,15 +39613,15 @@
-
-
-
-- if test x$SDL_CONFIG = xyes; then
-- sdl_cflags=`sdl-config --cflags`
-- sdl_libs=`sdl-config --libs`
-+ if test -n $SDL_CONFIG ; then
-+ sdl_cflags=`$SDL_CONFIG --cflags`
-+ sdl_libs=`$SDL_CONFIG --libs`
- fi
-
-
-
-
-- if test x$PKGCONFIGFOUND = xyes -a x$SDL_CONFIG = xyes; then
-+ if test x$PKGCONFIGFOUND = xyes -a -n $SDL_CONFIG ; then
-
-
- succeeded=no