aboutsummaryrefslogtreecommitdiff
path: root/audio/ardour
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ardour')
-rw-r--r--audio/ardour/Makefile22
-rw-r--r--audio/ardour/distinfo6
-rw-r--r--audio/ardour/files/patch-SConstruct50
-rw-r--r--audio/ardour/pkg-plist7
4 files changed, 67 insertions, 18 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index becc64137b17..e6600e141fe1 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ardour
-PORTVERSION= 2.0.3
+PORTVERSION= 2.0.5
CATEGORIES= audio
MASTER_SITES= http://ardour.org/files/releases/
DISTFILES= ardour-${DISTVERSION}.tar.bz2
@@ -24,10 +24,11 @@ LIB_DEPENDS= lrdf.2:${PORTSDIR}/textproc/liblrdf \
gnomecanvasmm-2.6:${PORTSDIR}/graphics/libgnomecanvasmm26 \
sqlite3:${PORTSDIR}/databases/sqlite3 \
lo.6:${PORTSDIR}/audio/liblo \
- SoundTouch.0:${PORTSDIR}/audio/soundtouch
+ SoundTouch.0:${PORTSDIR}/audio/soundtouch \
+ usb:${PORTSDIR}/devel/libusb
USE_SCONS= yes
-SCONS_ENV+= SYSLIBS=yes PREFIX=${PREFIX} NLS=yes FPU_OPTIMIZATION=0
+SCONS_ENV+= SYSLIBS=yes PREFIX=${PREFIX} NLS=yes
CFLAGS+= -I${LOCALBASE}/include
USE_BZIP2= yes
USE_GNOME= gtk20 libxslt libgnomecanvas intltool
@@ -65,8 +66,21 @@ PLIST_SUB+= VST="@comment "
# Upstream uses these flags by default.
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
-# XXX: what about SSE?
CFLAGS+= -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce
+
+.if ${ARCH} == "amd64"
+SCONS_ENV+= DIST_TARGET=x86_64
+SCONS_ENV+= FPU_OPTIMIZATION=1
+.elif ${MACHINE_CPU:Msse}
+SCONS_ENV+= DIST_TARGET=i686
+SCONS_ENV+= FPU_OPTIMIZATION=1
+.else
+SCONS_ENV+= DIST_TARGET=i386
+SCONS_ENV+= FPU_OPTIMIZATION=0
+.endif
+
+.else
+SCONS_ENV+= FPU_OPTIMIZATION=0
.endif
CFLAGS:= ${CFLAGS:N-fno-strict-aliasing}
diff --git a/audio/ardour/distinfo b/audio/ardour/distinfo
index 4ad7d50cdd95..72c97f24639e 100644
--- a/audio/ardour/distinfo
+++ b/audio/ardour/distinfo
@@ -1,6 +1,6 @@
-MD5 (ardour-2.0.3.tar.bz2) = d047d3f9e7b5b4bf80980c5b267c1068
-SHA256 (ardour-2.0.3.tar.bz2) = 36df4728b92aaab141ed7dbfab4c29f8a1fb83e4ebb95bc2ffa40c831f4d787e
-SIZE (ardour-2.0.3.tar.bz2) = 2745744
+MD5 (ardour-2.0.5.tar.bz2) = 7ac25b5837284fcae2ab3cb6825dc369
+SHA256 (ardour-2.0.5.tar.bz2) = 976b87920a3bd481b06edcbc756d1c5425397286f9b2a14546705a1f60a60848
+SIZE (ardour-2.0.5.tar.bz2) = 2777524
MD5 (vst_sdk2_3.zip) = c91d3be58ad4e9c695d0a90b2198be0d
SHA256 (vst_sdk2_3.zip) = 5400e0bbfeef0ab8a67b48899a9e8067db47552f43b30d8d15323ab999523226
SIZE (vst_sdk2_3.zip) = 4147357
diff --git a/audio/ardour/files/patch-SConstruct b/audio/ardour/files/patch-SConstruct
index 2e4ace440b80..69952fbee956 100644
--- a/audio/ardour/files/patch-SConstruct
+++ b/audio/ardour/files/patch-SConstruct
@@ -1,5 +1,5 @@
---- SConstruct.orig Mon Jul 2 19:14:26 2007
-+++ SConstruct Wed Jul 4 14:23:38 2007
+--- SConstruct.orig 2007-08-01 07:04:48.000000000 +0200
++++ SConstruct 2007-09-06 11:09:13.000000000 +0200
@@ -38,7 +38,7 @@
BoolOption('FPU_OPTIMIZATION', 'Build runtime checked assembler code', 1),
BoolOption('LIBLO', 'Compile with support for liblo library', 1),
@@ -18,7 +18,33 @@
if os.path.isfile('.personal_use_only'):
print "Enabling VST support. Note that distributing a VST-enabled ardour\nis a violation of several different licences.\nBuild with VST=false if you intend to distribute ardour to others."
else:
-@@ -668,13 +668,7 @@
+@@ -597,9 +597,9 @@
+ opt_flags.extend (["-mhard-float", "-mpowerpc-gfxopt"])
+ opt_flags.extend (["-Os"])
+
+-elif ((re.search ("i[0-9]86", config[config_cpu]) != None) or (re.search ("x86_64", config[config_cpu]) != None)) and env['DIST_TARGET'] != 'none':
++elif ((re.search ("i[0-9]86", env['DIST_TARGET']) != None) or (re.search ("x86_64", env['DIST_TARGET']) != None)):
+
+- build_host_supports_sse = 0
++ build_host_supports_sse = 1
+
+ debug_flags.append ("-DARCH_X86")
+ opt_flags.append ("-DARCH_X86")
+@@ -644,12 +644,7 @@
+ print "\nWarning: you are building Ardour with SSE support even though your system does not support these instructions. (This may not be an error, especially if you are a package maintainer)"
+ # end optimization section
+
+-# handle x86/x86_64 libdir properly
+-
+-if env['DIST_TARGET'] == 'x86_64':
+- env['LIBDIR']='lib64'
+-else:
+- env['LIBDIR']='lib'
++env['LIBDIR']='lib'
+
+ #
+ # save off guessed arch element in an env
+@@ -668,13 +663,7 @@
# prepend boiler plate optimization flags
#
@@ -33,7 +59,15 @@
if env['DEBUG'] == 1:
env.Append(CCFLAGS=" ".join (debug_flags))
-@@ -771,6 +765,7 @@
+@@ -719,6 +708,7 @@
+
+ libraries['usb'] = LibraryInfo ()
+ prep_libcheck(env, libraries['usb'])
++libraries['usb'].Append(CCFLAGS="-I/usr/local/include", LINKFLAGS="-L/usr/local/lib")
+
+ conf = Configure (libraries['usb'])
+ if conf.CheckLib ('usb', 'usb_interrupt_write'):
+@@ -777,6 +767,7 @@
if env['LIBLO']:
libraries['lo'] = LibraryInfo ()
prep_libcheck(env, libraries['lo'])
@@ -41,7 +75,7 @@
conf = Configure (libraries['lo'])
if conf.CheckLib ('lo', 'lo_server_new') == False:
-@@ -784,6 +779,7 @@
+@@ -790,6 +781,7 @@
libraries['dmalloc'] = LibraryInfo ()
prep_libcheck(env, libraries['dmalloc'])
@@ -49,7 +83,7 @@
#
# look for the threaded version
-@@ -815,8 +811,10 @@
+@@ -821,8 +813,10 @@
subst_dict['%MIDITAG%'] = "ardour"
subst_dict['%MIDITYPE%'] = "coremidi"
else:
@@ -62,7 +96,7 @@
env = conf.Finish()
-@@ -986,8 +984,7 @@
+@@ -992,8 +986,7 @@
surface_subdirs = [ 'libs/surfaces/control_protocol',
'libs/surfaces/generic_midi',
'libs/surfaces/tranzport',
@@ -72,7 +106,7 @@
]
if env['SURFACES']:
-@@ -1090,8 +1087,8 @@
+@@ -1106,8 +1099,8 @@
subst_dict['%JACK_INPUT%'] = "coreaudio:Built-in Audio:in"
subst_dict['%JACK_OUTPUT%'] = "coreaudio:Built-in Audio:out"
else:
diff --git a/audio/ardour/pkg-plist b/audio/ardour/pkg-plist
index f5f58ea9b26e..d09c2d87c155 100644
--- a/audio/ardour/pkg-plist
+++ b/audio/ardour/pkg-plist
@@ -11,16 +11,17 @@ lib/ardour2/libgtkmm2ext.so
lib/ardour2/libardour_cp.so
lib/ardour2/surfaces/libardour_genericmidi.so
lib/ardour2/surfaces/libardour_mackie.so
+lib/ardour2/surfaces/libardour_tranzport.so
@dirrm lib/ardour2/surfaces
lib/ardour2/engines/libclearlooks.so
@dirrm lib/ardour2/engines
@dirrm lib/ardour2
-etc/ardour2/ardour2_ui.rc
etc/ardour2/ardour.menus
etc/ardour2/ardour.bindings
-etc/ardour2/ardour.colors
etc/ardour2/ardour_system.rc
-etc/ardour2/ardour.rc
+etc/ardour2/ardour2_ui_dark.rc
+etc/ardour2/ardour2_ui_light.rc
+etc/ardour2/ardour2_ui_default.conf
@dirrmtry etc/ardour2
share/ardour2/splash.png
share/ardour2/pixmaps/hslider00.xpm