aboutsummaryrefslogtreecommitdiff
path: root/audio/ascd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ascd/Makefile')
-rw-r--r--audio/ascd/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/audio/ascd/Makefile b/audio/ascd/Makefile
index ea169edc278f..398df0f0c47c 100644
--- a/audio/ascd/Makefile
+++ b/audio/ascd/Makefile
@@ -16,17 +16,21 @@ MAINTAINER= jim@FreeBSD.org
LIB_DEPENDS= workman.1:${PORTSDIR}/audio/libworkman
WRKSRC= ${WRKDIR}/${PKGNAME}
+
USE_IMAKE= yes
USE_XPM= yes
-HAS_CONFIGURE= yes
-CONFIGURE_SCRIPT= default
+
DATAFILES= ascd-0.13pr6-themes.tgz
THEMESDIR= ascd-0.13pr6-themes
MAN1= ascd.1
post-patch:
- @${LN} -fs ${WRKSRC}/misc/default ${WRKSRC}/default
+ @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" \
+ ${WRKSRC}/misc/config.h.default > ${WRKSRC}/config.h
+ @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" \
+ ${WRKSRC}/misc/dirs.h.default > ${WRKSRC}/dirs.h
+ @${CAT} ${WRKSRC}/version.h >> ${WRKSRC}/config.h
post-install:
@${CP} ${FILESDIR}/install ${WRKDIR}/${THEMESDIR}