aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/audacity/Makefile')
-rw-r--r--audio/audacity/Makefile42
1 files changed, 14 insertions, 28 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 5da9f5a586cd..236b45eaf94b 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 2.0.5
-PORTREVISION= 3
+PORTVERSION= 2.0.6
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE \
SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
@@ -18,9 +17,9 @@ LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}
-USE_AUTOTOOLS= aclocal autoconf
GNU_CONFIGURE= yes
-USES= tar:xz desktop-file-utils gmake gettext pkgconfig shared-mime-info
+USES= desktop-file-utils gettext gmake pkgconfig shared-mime-info \
+ tar:xz
USE_WX= 2.8
WX_UNICODE= yes
WX_COMPS= wx
@@ -30,7 +29,7 @@ PORTDOCS= README.txt
OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME MAD MIDI NYQUIST \
PORTMIXER SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS
OPTIONS_RADIO= SAMPLERATED
-OPTIONS_RADIO_SAMPLERATED= RESAMPLE SAMPLERATE SOXR
+OPTIONS_RADIO_SAMPLERATED= SAMPLERATE SOXR
OPTIONS_DEFAULT= FFMPEG FLAC ID3TAG LADSPA MAD MIDI NYQUIST \
PORTMIXER SBSMS SOUNDTOUCH SOXR TWOLAME VAMP VORBIS
@@ -39,7 +38,6 @@ LAME_DESC= Use lame for import and export support
MAD_DESC= Use libmad for mp2/3 decoding support
MIDI_DESC= Use portSMF for Midi support
NYQUIST_DESC= Nyquist plug-in support
-RESAMPLE_DESC= Use libresample for sample rate conversion
SAMPLERATE_DESC= Use libsamplerate for sample rate conversion
SAMPLERATED_DESC= Default sample rate conversion support
PORTMIXER_DESC= Compile with PortMixer support
@@ -50,15 +48,11 @@ TAGLIB_DESC= Use TagLib for metadata support
TWOLAME_DESC= Use libtwolame for MP2 export support
VAMP_DESC= Vamp plug-in support
-ACLOCAL_ARGS+= -I ${WRKSRC}/m4
-AUTOCONF_ARGS+= -I ${WRKSRC}/m4
-
-CONFIGURE_ARG+= --destdir=/
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
CONFIGURE_ARGS+= --with-lib-preference="local system" \
- --with-portaudio --enable-unicode
+ --enable-portaudio --enable-unicode --without-lv2
.if ${MACHINE_CPU:Msse}
CONFIGURE_ARGS+= --enable-sse
@@ -69,11 +63,10 @@ CONFIGURE_ARGS+= --disable-sse
DEBUG_CONFIGURE_WITH= debug
FFMPEG_CONFIGURE_WITH= ffmpeg
-FFMPEG_RUN_DEPENDS= ffmpeg0:${PORTSDIR}/multimedia/ffmpeg0
-FFMPEG_BUILD_DEPENDS= ffmpeg0>=0:${PORTSDIR}/multimedia/ffmpeg0
-FFMPEG_CFLAGS= -I${LOCALBASE}/include/ffmpeg0
-FFMPEG_CPPFLAGS= -I${LOCALBASE}/include/ffmpeg0
-FFMPEG_CXXFLAGS= -I${LOCALBASE}/include/ffmpeg0
+FFMPEG_RUN_DEPENDS= ${LOCALBASE}/bin/ffmpeg:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_CFLAGS= -I${LOCALBASE}/include/ffmpeg
+FFMPEG_CPPFLAGS= -I${LOCALBASE}/include/ffmpeg
+FFMPEG_CXXFLAGS= -I${LOCALBASE}/include/ffmpeg
FLAC_CONFIGURE_WITH= libflac
FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
@@ -98,8 +91,6 @@ NYQUIST_CONFIGURE_ENABLE= nyquist
PORTMIXER_CONFIGURE_WITH= portmixer
-RESAMPLE_CONFIGURE_WITH= libresample
-
SAMPLERATE_CONFIGURE_WITH= libsamplerate
SAMPLERATE_LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
@@ -122,19 +113,14 @@ VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
.include <bsd.port.pre.mk>
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CPPFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-CXXFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-CFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${WRKSRC}/lib-src/portsmf ${PTHREAD_CFLAGS}
+CXXFLAGS+= -I${WRKSRC}/lib-src/portsmf ${PTHREAD_CFLAGS}
+CFLAGS+= -I${WRKSRC}/lib-src/portsmf -I${WRKSRC}/lib-src/portaudio-v19/include -I${WRKSRC}/lib-src/lame -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
post-patch:
-#audacity links to some dependencies if present, even if explicitly disabled.
-#these must be patched out for the case when they are installed but
-#option-disabled to avoid unrecorded dependencies.
-
-.if empty(PORT_OPTIONS:MSAMPLERATE)
- @${REINPLACE_CMD} -e 's|libresample.a -lsamplerate $(LIBS)|libresample.a $(LIBS)|' ${WRKSRC}/lib-src/libresample/Makefile.in
+.if ! ${PORT_OPTIONS:MPORTMIXER}
+ @${REINPLACE_CMD} -e 's/ portmixer / /' ${WRKSRC}/lib-src/Makefile.in
.endif
-
@${REINPLACE_CMD} -e 's|inline void|static inline void|' ${WRKSRC}/lib-src/libnyquist/nyquist/ffts/src/fftlib.c
post-install: