aboutsummaryrefslogtreecommitdiff
path: root/audio/ccaudio2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ccaudio2/Makefile')
-rw-r--r--audio/ccaudio2/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/ccaudio2/Makefile b/audio/ccaudio2/Makefile
index cccbb55c8adf..e54d85bf5021 100644
--- a/audio/ccaudio2/Makefile
+++ b/audio/ccaudio2/Makefile
@@ -27,6 +27,12 @@ MAN3= Audio.3cc AudioCodec.3cc AudioCopy.3cc AudioFile.3cc \
AudioSample.3cc AudioTone.3cc CDAudio.3cc DTMFDetect.3cc \
LinearSample.3cc
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64 (shared libraries must be compiled with -fPIC)"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|<stdint\.h>|<stdlib.h>|g' ${WRKSRC}/src/dtmf.cpp
@@ -34,4 +40,4 @@ post-patch:
pre-configure:
@${CP} ${LTMAIN} ${WRKSRC}/config
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>