aboutsummaryrefslogtreecommitdiff
path: root/audio/cmus
diff options
context:
space:
mode:
Diffstat (limited to 'audio/cmus')
-rw-r--r--audio/cmus/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index d3bf90f51f2d..7b726c9db1fa 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -18,11 +18,9 @@ COMMENT= Console-based music player with really cool features
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to configure: checking for successful build of ffmpeg.c... no
-
+USES= compiler:c11 gmake iconv ncurses pkgconfig
USE_GITHUB= yes
-USES= gmake iconv ncurses pkgconfig
HAS_CONFIGURE= yes
CONFIGURE_ARGS= prefix=${PREFIX} mandir=${MANPREFIX}/man \
exampledir=${EXAMPLESDIR}
@@ -31,7 +29,8 @@ CONFIGURE_ARGS= prefix=${PREFIX} mandir=${MANPREFIX}/man \
CONFIGURE_ARGS+= HOSTCC=${CC}
# Verbose build makes it easier to spot problems
-MAKE_ARGS= V=2
+MAKE_ARGS= V=2 ${MAKE_ARGS_${ARCH:U}}
+MAKE_ARGS_powerpc= COMPAT_LIBS="-latomic" # undefined reference to `__atomic_fetch_add_8'
# Disable all configure options first. These will be overwritten by
# enabled port options later. The args to cmus' configure script