aboutsummaryrefslogtreecommitdiff
path: root/audio/csound/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/csound/Makefile')
-rw-r--r--audio/csound/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 6ff17132b1d2..74f2bdb0ed9d 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -156,6 +156,12 @@ WIIMOTE_DESC= Build the Wiimote opcodes
WIIMOTE_CMAKE_BOOL= BUILD_WIIMOTE_OPCODES
WIIMOTE_BROKEN= Need to port wiiuse: https://github.com/rpavlik/wiiuse
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BROKEN_FreeBSD_11= libcsound64.so.6.0: undefined reference to `__atomic_store_8' / undefined reference to `__atomic_load_8'
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/local|${LOCALBASE}|' \
@@ -185,4 +191,4 @@ post-install:
post-install-FLTK-on:
@${LN} -sf libCsoundAC.so.6.0 ${STAGEDIR}${PREFIX}/lib/libCsoundAC.so.6
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>