aboutsummaryrefslogtreecommitdiff
path: root/audio/csound
diff options
context:
space:
mode:
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile2
-rw-r--r--audio/csound/files/patch-aops.c16
2 files changed, 16 insertions, 2 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 9a62c93d1d57..592bd26c66e7 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -15,8 +15,6 @@ EXTRACT_ONLY= Csound${PORTVERSION}.tar.gz
MAINTAINER= trevor@FreeBSD.org
-BROKEN= "Fails to compile"
-
LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83 \
tk83:${PORTSDIR}/x11-toolkits/tk83
diff --git a/audio/csound/files/patch-aops.c b/audio/csound/files/patch-aops.c
new file mode 100644
index 000000000000..0dd3e34b94d1
--- /dev/null
+++ b/audio/csound/files/patch-aops.c
@@ -0,0 +1,16 @@
+--- aops.c.orig Thu Jan 4 03:48:26 2001
++++ aops.c Thu Mar 15 06:26:31 2001
+@@ -1,3 +1,4 @@
++#include <sys/time.h>
+ #include "cs.h" /* AOPS.C */
+ #include "aops.h"
+ #include <math.h>
+@@ -421,8 +422,6 @@
+ #ifdef LINUX
+ void rtclock(EVAL *p)
+ {
+-#include <sys/time.h>
+-#include <unistd.h>
+ struct timeval tv;
+ struct timezone tz;
+ gettimeofday(&tv, &tz);