aboutsummaryrefslogtreecommitdiff
path: root/audio/darkice
diff options
context:
space:
mode:
Diffstat (limited to 'audio/darkice')
-rw-r--r--audio/darkice/Makefile28
-rw-r--r--audio/darkice/distinfo1
-rw-r--r--audio/darkice/pkg-comment1
-rw-r--r--audio/darkice/pkg-descr8
-rw-r--r--audio/darkice/pkg-plist2
5 files changed, 40 insertions, 0 deletions
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
new file mode 100644
index 000000000000..ef773dcc4331
--- /dev/null
+++ b/audio/darkice/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: darkice
+# Date created: Dec 28, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= darkice
+PORTVERSION= 0.7
+CATEGORIES= audio net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= mp3lame:${PORTSDIR}/audio/lame-devel \
+ ogg:${PORTSDIR}/audio/libogg \
+ vorbis:${PORTSDIR}/audio/libvorbis
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-lame-prefix=${LOCALBASE} \
+ --with-vorbis-prefix=${LOCALBASE}
+
+MAN1= darkice.1
+MAN5= darkice.cfg.5
+
+.include <bsd.port.mk>
diff --git a/audio/darkice/distinfo b/audio/darkice/distinfo
new file mode 100644
index 000000000000..730549872cb7
--- /dev/null
+++ b/audio/darkice/distinfo
@@ -0,0 +1 @@
+MD5 (darkice-0.7.tar.gz) = b9caf6a9c0add4a698119fbfbb6dad8b
diff --git a/audio/darkice/pkg-comment b/audio/darkice/pkg-comment
new file mode 100644
index 000000000000..274097213cce
--- /dev/null
+++ b/audio/darkice/pkg-comment
@@ -0,0 +1 @@
+DarkIce is an IceCast, IceCast2 and ShoutCast live audio streamer
diff --git a/audio/darkice/pkg-descr b/audio/darkice/pkg-descr
new file mode 100644
index 000000000000..383be35521a8
--- /dev/null
+++ b/audio/darkice/pkg-descr
@@ -0,0 +1,8 @@
+DarkIce is an IceCast, IceCast2 and ShoutCast live audio streamer. It takes
+audio input from a sound card, encodes it into mp3 and/or Ogg Vorbis, and
+sends the mp3 stream to one or more IceCast and/or ShoutCast servers, the
+Ogg Vorbis stream to one or more IceCast2 servers. DarkIce uses lame as a
+shared object as its mp3 encoder, and the Ogg Vorbis as its Ogg Vorbis
+encoder.
+
+WWW: http://darkice.sourceforge.net/
diff --git a/audio/darkice/pkg-plist b/audio/darkice/pkg-plist
new file mode 100644
index 000000000000..7d57b17db947
--- /dev/null
+++ b/audio/darkice/pkg-plist
@@ -0,0 +1,2 @@
+bin/darkice
+etc/darkice.cfg