aboutsummaryrefslogtreecommitdiff
path: root/audio/esperanza/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/esperanza/Makefile')
-rw-r--r--audio/esperanza/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/esperanza/Makefile b/audio/esperanza/Makefile
new file mode 100644
index 000000000000..d47ec14c6e91
--- /dev/null
+++ b/audio/esperanza/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: esperanza
+# Date created: 23 Feb 2007
+# Whom: Alexander Botero-Lowry <alexbl@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= esperanza
+PORTVERSION= 0.2.2
+CATEGORIES= audio
+MASTER_SITES= http://xmms2.xmms.se/~tru/esperanza/0.2/
+
+MAINTAINER= alexbl@FreeBSD.org
+COMMENT= Advanced QT4 XMMS2 client
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so:${PORTSDIR}/audio/cpp-xmms2
+RUN_DEPENDS= ${LOCALBASE}/lib/libxmmsclient++.so:${PORTSDIR}/audio/cpp-xmms2
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc qmake rcc uic xml network imageformats
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/esperanza
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} -unix PREFIX=${PREFIX} esperanza.pro
+
+.include <bsd.port.mk>