aboutsummaryrefslogtreecommitdiff
path: root/audio/exaile-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/exaile-devel/Makefile')
-rw-r--r--audio/exaile-devel/Makefile40
1 files changed, 0 insertions, 40 deletions
diff --git a/audio/exaile-devel/Makefile b/audio/exaile-devel/Makefile
deleted file mode 100644
index f0b443db1c5e..000000000000
--- a/audio/exaile-devel/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# New ports collection makefile for: exaile
-# Date created: 19 December 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= exaile
-DISTVERSION= 0.2.8
-CATEGORIES= audio
-MASTER_SITES= http://www.exaile.org/files/ CSME
-DISTNAME= ${PORTNAME}_${DISTVERSION}
-
-MAINTAINER= infofarmer@FreeBSD.org
-COMMENT= AmaroK replacement for GTK+
-
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus \
- ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/__init__.py:${PORTSDIR}/devel/py-notify \
- ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree \
- ${PYTHON_SITELIBDIR}/mutagen/__init__.py:${PORTSDIR}/audio/py-mutagen \
- ${PYTHON_SITELIBDIR}/gtk-2.0/sexy.so:${PORTSDIR}/x11-toolkits/py-sexy \
- ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-
-USE_GNOME= pygtk2 pygnomeextras
-USE_GSTREAMER= python
-USE_PYTHON= yes
-PLIST_FILES= share/applications/${PORTNAME}.desktop share/pixmaps/${PORTNAME}.png bin/${PORTNAME}
-
-post-patch:
- @${REINPLACE_CMD} -e '/^PREFIX/d' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e '/^PYTHON_DIR/s|=.*|=${PYTHON_INCLUDEDIR}|' ${WRKSRC}/mmkeys/Makefile
-
-create-plist:
- ${FIND} -s ${DATADIR} -not -type d|${SED} -e 's|^${DATADIR}|%%DATADIR%%|' > ${PLIST}
- ${FIND} -ds ${DATADIR} -type d|${SED} -e 's|^${DATADIR}|%%DATADIR%%|' \
- -e 's|^|@dirrm |' >> ${PLIST}
- @${ECHO_CMD} '@dirrmtry share/applications' >> ${PLIST}
- @${ECHO_CMD} '@dirrmtry share/pixmaps' >> ${PLIST}
-
-.include <bsd.port.mk>