aboutsummaryrefslogtreecommitdiff
path: root/audio/fcplay/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/fcplay/Makefile')
-rw-r--r--audio/fcplay/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/fcplay/Makefile b/audio/fcplay/Makefile
index ceb2d8ce8213..92f89b43dbce 100644
--- a/audio/fcplay/Makefile
+++ b/audio/fcplay/Makefile
@@ -18,6 +18,12 @@ COMMENT= Future Composer Reference Player
BUILD_DEPENDS= ${LOCALBASE}/include/sidplay/compconf.h:${PORTSDIR}/audio/libsidplay
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
@@ -32,4 +38,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/POINTER ${PREFIX}/share/doc/fcplay
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>