aboutsummaryrefslogtreecommitdiff
path: root/audio/flac/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/flac/Makefile')
-rw-r--r--audio/flac/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index bc592aa61516..041f2aab7cd2 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -16,14 +16,14 @@ COMMENT= Free lossless audio codec
LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
-.if ${MACHINE_ARCH} == "i386"
+.if ${ARCH} == "i386"
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
.endif
USE_ICONV= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_TARGET= --target=${ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --enable-sse \
--with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}"