aboutsummaryrefslogtreecommitdiff
path: root/audio/ices
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ices')
-rw-r--r--audio/ices/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/audio/ices/Makefile b/audio/ices/Makefile
index e0c77e10143d..719fc488b40c 100644
--- a/audio/ices/Makefile
+++ b/audio/ices/Makefile
@@ -20,10 +20,13 @@ LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
vorbis.2:${PORTSDIR}/audio/libvorbis \
xml2.5:${PORTSDIR}/textproc/libxml2
+AUTOMAKE_ARGS= --add-missing
+AUTOMAKE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-oggtest --disable-vorbistest --disable-shouttest
CONFIGURE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-GNU_CONFIGURE= yes
+USE_AUTOMAKE_VER=15
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes