aboutsummaryrefslogtreecommitdiff
path: root/audio/id3lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/id3lib/Makefile')
-rw-r--r--audio/id3lib/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index becde3771bd4..a85f492e3817 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -6,25 +6,30 @@
#
PORTNAME= id3lib
-PORTVERSION= 3.7.13
+PORTVERSION= 3.8.2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= roman@xpert.com
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
INSTALLS_SHLIB= yes
-USE_LIBTOOL= yes
-USE_AUTOMAKE= yes
-USE_GMAKE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+BROKEN= "Doesn't link properly, std::char_traits<wchar_t> thingie"
+.endif
+
post-extract:
-.for i in zlib popt
- ${RM} -rf ${WRKSRC}/$i
-.endfor
+ @${RM} -rf ${WRKSRC}/zlib
+
+post-install:
+ @${RM} -f ${LOCALBASE}/lib/libid3.la
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>