aboutsummaryrefslogtreecommitdiff
path: root/audio/id3ren/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/id3ren/Makefile')
-rw-r--r--audio/id3ren/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/audio/id3ren/Makefile b/audio/id3ren/Makefile
index e48ddc4f796f..b9b473a6aca6 100644
--- a/audio/id3ren/Makefile
+++ b/audio/id3ren/Makefile
@@ -16,10 +16,7 @@ GH_ACCOUNT= sebcode
GH_TAGNAME= 322ee77
GH_COMMIT= 322ee77
-NO_STAGE= yes
-PLIST_FILES= bin/id3ren
-MAN1= id3ren.1
-MANCOMPRESSED= yes
+PLIST_FILES= bin/id3ren man/man1/id3ren.1.gz
PORTDOCS= AUTHORS ChangeLog FEATURES FEEDBACK INSTALL PORTS \
README THANKS TODO USAGE
@@ -30,10 +27,13 @@ pre-patch:
${WRKSRC}/src/id3ren.c ${WRKSRC}/src/id3misc.c
${RM} ${WRKSRC}/src/id3ren
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1.gz \
+ ${STAGEDIR}${PREFIX}/man/man1/
+
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>