aboutsummaryrefslogtreecommitdiff
path: root/audio/libmusicbrainz5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/libmusicbrainz5/Makefile')
-rw-r--r--audio/libmusicbrainz5/Makefile25
1 files changed, 6 insertions, 19 deletions
diff --git a/audio/libmusicbrainz5/Makefile b/audio/libmusicbrainz5/Makefile
index 7973c3b17f45..de8f8ecc2008 100644
--- a/audio/libmusicbrainz5/Makefile
+++ b/audio/libmusicbrainz5/Makefile
@@ -6,33 +6,20 @@
#
PORTNAME= musicbrainz
-PORTVERSION= 1.0.0
+PORTVERSION= 1.0.1
CATEGORIES= audio
MASTER_SITES= ftp://ftp.musicbrainz.org/pub/musicbrainz/
MAINTAINER= roman@xpert.com
-USE_AUTOCONF= yes
-USE_GMAKE= yes
USE_BZIP2= yes
-USE_LIBTOOL= yes
USE_NEWGCC= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-
-pre-extract:
-.if !defined(WITHOUT_VORBIS)
- @${ECHO}
- @${ECHO} "You can disable Vorbis support by defining WITHOUT_VORBIS"
- @${ECHO}
-LIB_DEPENDS+= vorbis.0:${PORTSDIR}/audio/libvorbis
-HAVE_VORBIS= yes
-.endif
-
-post-extract:
- @${RM} ${WRKSRC}/config.sub ${WRKSRC}/config.guess ;\
- ${LN} -s ${AUTOCONF_DIR}/config.* ${WRKSRC}/ ;\
- ${PERL} -pi -e 's/-ldl//g' ${WRKSRC}/examples/Makefile.*
+post-patch:
+ @${PERL} -pi -e 's|^CFLAGS=|#CFLAGS=|g ; \
+ s|^CPPFLAGS=|#CPPFLAGS=|g' ${WRKSRC}/configure
.include <bsd.port.mk>