aboutsummaryrefslogtreecommitdiff
path: root/audio/libsidplayfp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/libsidplayfp/Makefile')
-rw-r--r--audio/libsidplayfp/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/audio/libsidplayfp/Makefile b/audio/libsidplayfp/Makefile
index ff8fc7661bbd..e868739c0542 100644
--- a/audio/libsidplayfp/Makefile
+++ b/audio/libsidplayfp/Makefile
@@ -34,8 +34,6 @@ MMX_CONFIGURE_ENABLE= mmx
BUILD_DEPENDS+= xa65:${PORTSDIR}/devel/xa65
-.include <bsd.port.options.mk>
-
SIDPLAYFP_SHLIB_VERSION= 3.2.0
STILVIEW_SHLIB_VERSION= 0.0.2
PLIST_SUB+= \
@@ -44,17 +42,13 @@ PLIST_SUB+= \
STILVIEW_SHLIB_VER=${STILVIEW_SHLIB_VERSION:C/\.[[:digit:].]+//} \
STILVIEW_SHLIB_VERSION=${STILVIEW_SHLIB_VERSION}
-post-build:
-.if ${PORT_OPTIONS:MDOXYGEN}
+post-build-DOXYGEN-on:
cd ${WRKSRC} && ${MAKE} doc
-.endif
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR} ; \
cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MDOXYGEN}
+post-install-DOXYGEN-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html ; \
${INSTALL_MAN} ${WRKSRC}/docs/html/* ${STAGEDIR}${DOCSDIR}/html ; \
${RM} -f ${WRKDIR}/PLIST.doc ; \
@@ -62,6 +56,5 @@ post-install:
${SED} 's|${STAGEDIR}${PREFIX}/||' \
>> ${WRKDIR}/PLIST.doc
cd ${WRKDIR} ; ${SED} -i -e '/PLIST.doc/ r PLIST.doc' ${TMPPLIST}
-.endif
.include <bsd.port.mk>