aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-c6-openal-soft/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/linux-c6-openal-soft/Makefile')
-rw-r--r--audio/linux-c6-openal-soft/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/audio/linux-c6-openal-soft/Makefile b/audio/linux-c6-openal-soft/Makefile
new file mode 100644
index 000000000000..737270dbd01d
--- /dev/null
+++ b/audio/linux-c6-openal-soft/Makefile
@@ -0,0 +1,27 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= openal-soft
+PORTVERSION= 1.12.854
+CATEGORIES= audio linux
+MASTER_SITES= EPEL
+
+MAINTAINER= emulation@freebsd.org
+COMMENT= A 3D positional spatialized sound library (Linux CentOS ${LINUX_DIST_VER})
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+USE_LINUX_APPS= alsalib arts esound
+
+RPMVERSION= 1.el6
+USE_LDCONFIG= yes
+
+PLIST_FILES= usr/lib/libopenal.so.1 usr/lib/libopenal.so.${PORTVERSION} \
+ usr/bin/openal-info etc/openal/alsoft.conf
+PLIST_DIRS= etc/openal
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= COPYING
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>