aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-c7-alsa-plugins-oss/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/linux-c7-alsa-plugins-oss/Makefile')
-rw-r--r--audio/linux-c7-alsa-plugins-oss/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/audio/linux-c7-alsa-plugins-oss/Makefile b/audio/linux-c7-alsa-plugins-oss/Makefile
new file mode 100644
index 000000000000..fde0f1bbd202
--- /dev/null
+++ b/audio/linux-c7-alsa-plugins-oss/Makefile
@@ -0,0 +1,28 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= alsa-plugins-oss
+PORTVERSION= 1.0.27
+CATEGORIES= audio linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= OSS plugin for ALSA (Linux CentOS ${LINUX_DIST_VER})
+
+LICENSE= GPLv3
+
+CONFLICTS= linux-f10-${PORTNAME}-[0-9]* linux-c6-${PORTNAME}-[0-9]*
+
+SRC_DISTFILES= alsa-plugins-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}:SOURCE
+
+USES= linux:c7
+USE_LINUX= alsalib
+USE_LINUX_RPM= yes
+RPMVERSION= 3.el7
+
+USE_LDCONFIG= yes
+
+# We will use native configuration file, so delete a linux one
+post-extract:
+ @${RM} -r ${WRKSRC}/etc
+
+.include <bsd.port.mk>