aboutsummaryrefslogtreecommitdiff
path: root/audio/linuxsampler/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/linuxsampler/Makefile')
-rw-r--r--audio/linuxsampler/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/audio/linuxsampler/Makefile b/audio/linuxsampler/Makefile
index 3f1b59f89c8b..b434d1d71ace 100644
--- a/audio/linuxsampler/Makefile
+++ b/audio/linuxsampler/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://download.linuxsampler.org/packages/
MAINTAINER= ports@FreeBSD.org
COMMENT= Modular MIDI sampler
-LIB_DEPENDS= libgig.so:${PORTSDIR}/audio/libgig
+LIB_DEPENDS= libgig.so:audio/libgig
RESTRICTED= no commercial use
@@ -37,20 +37,20 @@ CONFIGURE_ARGS+=--disable-arts-driver
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= libjack.so:${PORTSDIR}/audio/jack
+LIB_DEPENDS+= libjack.so:audio/jack
.else
CONFIGURE_ARGS+=--disable-jack-driver
.endif
.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= libasound.so:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= libasound.so:audio/alsa-lib
.else
CONFIGURE_ARGS+=--disable-alsa-driver
.endif
.if ${PORT_OPTIONS:MDSSI}
-BUILD_DEPENDS+= dssi>=0:${PORTSDIR}/audio/dssi
-RUN_DEPENDS+= dssi>=0:${PORTSDIR}/audio/dssi
+BUILD_DEPENDS+= dssi>=0:audio/dssi
+RUN_DEPENDS+= dssi>=0:audio/dssi
PLIST_SUB+= DSSI=""
CPPFLAGS:= -I${LOCALBASE}/include/dssi ${CPPFLAGS}
.else
@@ -59,8 +59,8 @@ PLIST_SUB+= DSSI="@comment "
.endif
.if ${PORT_OPTIONS:MLV2CORE}
-BUILD_DEPENDS+= lv2core>=0:${PORTSDIR}/audio/lv2core
-RUN_DEPENDS+= lv2core>=0:${PORTSDIR}/audio/lv2core
+BUILD_DEPENDS+= lv2core>=0:audio/lv2core
+RUN_DEPENDS+= lv2core>=0:audio/lv2core
PLIST_SUB+= LV2CORE=""
.else
CONFIGURE_ENV+= ac_cv_header_lv2_h=no