aboutsummaryrefslogtreecommitdiff
path: root/audio/lv2core/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/lv2core/Makefile')
-rw-r--r--audio/lv2core/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/lv2core/Makefile b/audio/lv2core/Makefile
new file mode 100644
index 000000000000..546e882450e4
--- /dev/null
+++ b/audio/lv2core/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: lv2core
+# Date created: 2008-11-20
+# Whom: xaimus <xaimus@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lv2core
+PORTVERSION= 3.0
+CATEGORIES= audio
+MASTER_SITES= http://lv2plug.in/spec/
+
+MAINTAINER= xaimus@gmail.com
+COMMENT= LV2 Core Package
+
+USE_BZIP2= yes
+USE_PYTHON_BUILD= yes
+USE_GNOME= pkgconfig
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} DESTDIR=${LOCALBASE} ./waf configure
+
+do-build:
+ cd ${WRKSRC} && ./waf build
+
+do-install:
+ cd ${WRKSRC} && ./waf install
+
+.include <bsd.port.mk>