aboutsummaryrefslogtreecommitdiff
path: root/audio/marlin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/marlin/Makefile')
-rw-r--r--audio/marlin/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/audio/marlin/Makefile b/audio/marlin/Makefile
index abc814efdaa8..44da21330d08 100644
--- a/audio/marlin/Makefile
+++ b/audio/marlin/Makefile
@@ -6,7 +6,7 @@
PORTNAME= marlin
PORTVERSION= 0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,7 +19,8 @@ LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnometarget gstreamerplugins intlhack libgnomeui
+USE_GNOME= gnomeprefix gnomehack gnometarget intlhack libgnomeui
+USE_GSTREAMER= flac mad vorbis
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=15
@@ -28,4 +29,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= marlin.schemas
+.if !defined(PACKAGE_BUILDING) || defined(WITH_LAME)
+USE_GSTREAMER+= lame
+.endif
+
.include <bsd.port.mk>