aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3lint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mp3lint/Makefile')
-rw-r--r--audio/mp3lint/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/audio/mp3lint/Makefile b/audio/mp3lint/Makefile
index 54752bff5c96..0ba1b534041f 100644
--- a/audio/mp3lint/Makefile
+++ b/audio/mp3lint/Makefile
@@ -10,19 +10,18 @@ MASTER_SITES= http://erislabs.net/ianb/projects/${PORTNAME}/ \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Configurable tool to check collections of audio files
+LICENSE= GPLv2
+
BUILD_DEPENDS= libmp3-archive-perl>=0:${PORTSDIR}/audio/libmp3-archive-perl
-RUN_DEPENDS= libmp3-archive-perl>=0:${PORTSDIR}/audio/libmp3-archive-perl
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-NO_STAGE= yes
USE_PERL5= configure
USES= perl5
-MAN1= mp3lintsum.1 mp3lintskip.1 mp3lint.1
-MAN3= mp3lint-tools.3
-MAN5= mp3lintrc.5
-
post-patch:
- @${REINPLACE_CMD} -e '/^DESTINSTALLSYSCONFDIR/ s|DESTDIR|PREFIX|' \
- ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -e '/^INSTALLSYSCONFDIR/ s|/etc|${PREFIX}&|' ${WRKSRC}/Makefile.PL
+# It fails to build with error message as follows:
+# Can't write-open blib/man5/mp3lintrc.5: No such file or directory at /usr/local/lib/perl5/5.xx.y/ExtUtils/Command/MM.pm line zzz.
+ @${MKDIR} ${WRKSRC}/blib/man5/
.include <bsd.port.mk>